Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old May 20, 2009, 11:57 AM   #1
Junior Member
 
Join Date: May 2009
Posts: 2
Default Two 20D problems

1) Battery seems to run out quickly. Thought it was the battery and replaced. Does it with the new battery. Have three batteries, all Canon. Only way I can get some time out of them is to use the grip and put in two batteries.

2) AF won't focus. You can hear the lens shifting to focus but the pics come out blurry. I get some in focus. It's about a 50/50 deal. I've cleaned the contacts and tried different lenses.

I had an extended service plan but in the process of trying to renew it good old Ritz Camera couldn't find it and by the time I got to someone that would authorize it the plan had expired and I couldn't renew. I'm afraid that sending it back (besides that fact that it takes months to get it back) would be as costly as just buying a new body. Any ideas?
morgandoyle is offline   Reply With Quote
Sponsored Links
Old May 20, 2009, 12:30 PM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

How about the battery contacts (including the ones in the camera)? I'd clean them, too (ditto for the ones on the charger). Just be careful not to damage anything. Are you sure that your "new" battery hasn't been sitting on a shelf somewhere for years? They won't last forever.

Have you tried a different memory card (just in case it's failing in a way that's drawing more current)?

I'd also use all dials, switches and buttons on the camera (since the friction from using them can help to clean the contacts as they rub together, and you may have a touch of oxidation somewhere interfering with electrical connections).
JimC is offline   Reply With Quote
Old May 20, 2009, 1:28 PM   #3
Junior Member
 
Join Date: May 2009
Posts: 2
Default Two problems with 20D

I'm pretty sure it isn't the batteries. When I recharge them it doesn't take very long to recharge. I'm thinking they are getting about half way discharged. As a matter of fact, if i take the battery out for a little bit and put it back in it will work again for a short time. Could it be related to the CMOS battery? I don't think I have replaced it since I've had the camera. Just grasping at straws here.
morgandoyle is offline   Reply With Quote
Old May 20, 2009, 1:40 PM   #4
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

The "doesn't take long to recharge" part could indicate a faulty charger, too; depending on how far the batteries are depleted. ;-)

You may want to try a different one, just for giggles. I just bought a spare not long ago for my camera's batteries from Ebay (since I left my primary charger somewhere out of town and needed one fast).

Here's the same charger (and vendor), only the one I got was for Sony batteries (and it works just fine with my batteries for a Sony A700). I got it in a few days (fast shipping from this vendor). For the price ($7.99 delivered), I can't complain. :-) This one should work with batteries for your 20D:

http://cgi.ebay.com/ws/eBayISAPI.dll...m=270393394390

The same vendor also sells inexpensive generic batteries (and if your camera works for a bit after inserting a freshly charged battery, I'd still lean towards a power related issue causing your problems if you don't have a bit of oxidation on contacts somewhere interfering with electrical connections).
JimC is offline   Reply With Quote
Old May 21, 2009, 12:38 AM   #5
Senior Member
 
cock3tail's Avatar
 
Join Date: Feb 2004
Posts: 401
Default

I had similar problems.I put my 20D in for servicing and it came back with a message the reason was I had previously set the camera on some setting (that I can't remember now).
Try setting the camera to factory default.I'm referring to the failure to auto focus.

Last edited by cock3tail; May 21, 2009 at 12:45 AM.
cock3tail is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:55 PM.