Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Apr 24, 2010, 12:24 AM   #1
Member
 
Join Date: May 2004
Location: Monson, Maine
Posts: 52
Default 7D Firmware update

I recently received notice from Canon of a firmware update for the 7D. Version is 1.2.1 I have a 10D and never had to install a firmware update for it. I am a software consultant and have installed os updates for computers many many times over forty plus years and have often seen more problems created than solved in doing so. Have any of you installed this fix yet? If so, has anyone experienced any problems? I have had no problems yet with my 7D and am a firm believer in the "If it aint broke, don't fix it" rule.
dlearyfun is offline   Reply With Quote
Sponsored Links
Old Apr 24, 2010, 12:25 AM   #2
Super Moderator
 
Hards80's Avatar
 
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046
Default

there are rarely any problems with updating firmwares. it is a quick and painless process that usually adds significantly to your camera. if you follow their instructions and don't turn off the camera or anything while its updating, you will have no issues.
Hards80 is offline   Reply With Quote
Old Apr 24, 2010, 8:13 AM   #3
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,452
Default

I've updated my 1DmkIII and 5DmkII cameras with no issues at all. I'm not currently going to update my 7D as there isn't anything on the list that is affecting me. I don't take photo in ISO setting H while in movie mode, I don't shoot in Auto ISO, and I've not had an issue with shutdown due to over heating. Oh, and I don't speak French........ so there is no gain for me. If you don't have any of the issues then there is little point updating.
__________________
[SIZE=1][SIZE=2]Any problems with a post or thread please use the report button at the bottom left of the post and the team will help sort it out.
Mark1616 is offline   Reply With Quote
Old Apr 24, 2010, 3:49 PM   #4
Senior Member
 
Join Date: May 2008
Location: Dickson, Tennessee
Posts: 461
Default

Don't do the update. I, being somewhat anal about my gear, did the update to 1.2.1 and now my images suck! The shadow detail is noisy as hell and I am pissed!
shadokachr is offline   Reply With Quote
Old Apr 24, 2010, 3:55 PM   #5
Senior Member
 
Join Date: May 2008
Location: Dickson, Tennessee
Posts: 461
Default

Does anyone have a copy of the version 1.2.0 so I can reload the previous version?
shadokachr is offline   Reply With Quote
Old Apr 24, 2010, 8:41 PM   #6
Senior Member
 
Join Date: May 2008
Location: Dickson, Tennessee
Posts: 461
Default

Update! After a lengthy conversation with a Canon tech, it has been determined that a fairly new CF card was the culprit of my issues with the update. I used the new CF card for the firmware update, then reformatted the card and went out for a shoot. Some how the CF card became corrupted, and after a reformat it seems to be ok but I don't trust it. I lost a few good images, but luckily it was personal stuff, so no big deal. That CF card is history now.

It's generally a good idea to keep your updates current. If you don't it could cause issues later if an update comes out that you might want or need.
I don't speak French either, but software updates tend to be more than advertised.

Last edited by shadokachr; Apr 24, 2010 at 8:45 PM.
shadokachr is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:57 AM.