Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Nov 18, 2010, 1:50 AM   #1
Senior Member
 
Join Date: Nov 2009
Location: Ontario, Canada
Posts: 358
Default Add lens to Peripheral Illumination - T1i

Hi all,

Please forgive my post if this seems simple and obvious to many but I am having an issue with a lens bought for me with regards to Peripheral Illumination.

The lens 15-85 IS USM, is not listed on the camera - t1i. I upgraded the software from Canon's site (which I think I had the most recent anyway) and still its not listed within the list. I'm at a loss as to why its missing. I'm sure I'm missing something but I'm not sure as to what? I've placed my manual in a bag I don't currently have in my posession and trying to find the info on the net has been confusing.

Advice would be greatly appreciated.
__________________
Olympus E-PL5 45mm 1.8, 60mm macro and Panny 25mm 1.4

Canon 5D III
50mm 1.2 L l 24-70 F2.8 L l 70-200 F4 L l 40mm 2.8 l 100mmL 2.8 macro

http://www.facebook.com/pages/Alainn...39490172728282
http://alainnbellephotography.smugmug.com/
Shutterbug74 is offline   Reply With Quote
Sponsored Links
Old Nov 18, 2010, 2:30 AM   #2
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

That is a very new lens, it actually came out after the last firmware.
Your firmware should be 1.1.0

But you can add lenses to the camera. It only stores so many lenses. Here is a good read.
http://www.usa.canon.com/dlc/control...articleID=2027
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.

Last edited by shoturtle; Nov 18, 2010 at 2:45 AM.
shoturtle is offline   Reply With Quote
Old Nov 18, 2010, 8:34 PM   #3
Senior Member
 
Join Date: Nov 2009
Location: Ontario, Canada
Posts: 358
Default

Thanks Shoturtle....It was a good read. However how do I add/delete lenses when the 15-85 isn't even coming up on my list? I've reuploaded the software from the canon website and still its not listing the 15-85 as an option to select.

I see the screen that offers up a selection of lenses. I've even tried unclicking some but it has no effect. Am I missing something?
__________________
Olympus E-PL5 45mm 1.8, 60mm macro and Panny 25mm 1.4

Canon 5D III
50mm 1.2 L l 24-70 F2.8 L l 70-200 F4 L l 40mm 2.8 l 100mmL 2.8 macro

http://www.facebook.com/pages/Alainn...39490172728282
http://alainnbellephotography.smugmug.com/
Shutterbug74 is offline   Reply With Quote
Old Nov 18, 2010, 8:40 PM   #4
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

did you get the newest canon eos utility software. If not goto the software download form canon, update you eos utility software. And it should have the new list and when you plug up your t1i to the computer, you should be able to add it.
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.
shoturtle is offline   Reply With Quote
Old Nov 18, 2010, 9:09 PM   #5
Senior Member
 
Join Date: Nov 2009
Location: Ontario, Canada
Posts: 358
Default

Yes, I've downloaded version 2.8.1 from 11/6/10. Once its downloaded I've clicked on the EOS Utility Icon which opens up the proper screen. I clicked on Peripheral Illumination Correction and opened up the listing of EF and EF-S lenses but still the 15-85 isn't coming up as an option?
__________________
Olympus E-PL5 45mm 1.8, 60mm macro and Panny 25mm 1.4

Canon 5D III
50mm 1.2 L l 24-70 F2.8 L l 70-200 F4 L l 40mm 2.8 l 100mmL 2.8 macro

http://www.facebook.com/pages/Alainn...39490172728282
http://alainnbellephotography.smugmug.com/
Shutterbug74 is offline   Reply With Quote
Old Nov 18, 2010, 9:11 PM   #6
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

I would email canon, that is very strange, you have a very good lens, and it is strange canon did not put it into the latest version of it.

Quote:
Originally Posted by Shutterbug74 View Post
Yes, I've downloaded version 2.8.1 from 11/6/10. Once its downloaded I've clicked on the EOS Utility Icon which opens up the proper screen. I clicked on Peripheral Illumination Correction and opened up the listing of EF and EF-S lenses but still the 15-85 isn't coming up as an option?
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.
shoturtle is offline   Reply With Quote
Old Nov 18, 2010, 9:23 PM   #7
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

i just looked, it is there. Scroll all the way to the right. It is half way down the second to last roll of lenses, ef-s 15-85. Make sure you do not have selected lens only high lighted.
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.
shoturtle is offline   Reply With Quote
Old Nov 18, 2010, 10:15 PM   #8
Senior Member
 
Join Date: Nov 2009
Location: Ontario, Canada
Posts: 358
Default

I have attached the last 2 pages in pdf format so that you can see what I am looking at. I don't have the "selected lens" button clicked. It is showing all options, just not the 15-85. I am wondering if it just isn't downloading properly for some reason? I run my system off of Vista.
Attached Images
File Type: pdf EOS lenses.pdf (118.2 KB, 316 views)
__________________
Olympus E-PL5 45mm 1.8, 60mm macro and Panny 25mm 1.4

Canon 5D III
50mm 1.2 L l 24-70 F2.8 L l 70-200 F4 L l 40mm 2.8 l 100mmL 2.8 macro

http://www.facebook.com/pages/Alainn...39490172728282
http://alainnbellephotography.smugmug.com/
Shutterbug74 is offline   Reply With Quote
Old Nov 18, 2010, 10:19 PM   #9
Senior Member
 
shoturtle's Avatar
 
Join Date: Dec 2009
Location: Frankfurt AM
Posts: 11,348
Default

very strange, I see it on my mac it is the second to last column. But the last column matches up with what my mac sees.
__________________
Super Frequent Flyer, no joke. Ex Patriot and loving it.
Canon Eos 60D, T1i/500D, Eos1, Eos 630, Olympus EPL-1, and a part time Pentax K-X shooter.
shoturtle is offline   Reply With Quote
Old Nov 19, 2010, 7:39 PM   #10
Senior Member
 
Join Date: Nov 2009
Location: Ontario, Canada
Posts: 358
Default

For anyone reading this in the future. It was a downloading problem. After 4 attempts, it finally downloaded properly to my laptop. So, if anyone else has issues, try it a few times and it should work. But, download the DPP software first and then the others. That was the only thing I did different the last time around.
__________________
Olympus E-PL5 45mm 1.8, 60mm macro and Panny 25mm 1.4

Canon 5D III
50mm 1.2 L l 24-70 F2.8 L l 70-200 F4 L l 40mm 2.8 l 100mmL 2.8 macro

http://www.facebook.com/pages/Alainn...39490172728282
http://alainnbellephotography.smugmug.com/
Shutterbug74 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:40 PM.