Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Apr 21, 2011, 10:21 PM   #1
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default 7D on-board flash problem

I'm a bit puzzled and I wonder if anyone can advise me. I used my pretty new 7D outside today, amongst other things taking pictures of some blossom on a tree. Just playing around. I took non-flash pictures with the camera set to "P" and they came out nicely exposed, but possibly with a little blurring as the branches were being blown around by the wind. I then popped up the internal flash and took more, still on "P". These were all severely under-exposed. I know the flash fired, and I don't understand what happened. I intended the flash to be a "fill-in" with the exposure otherwise unaffected, but the effect was far from that. The flash is set to ETTL II and wireless is enabled.

Anyone any ideas?
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Sponsored Links
Old Apr 21, 2011, 11:00 PM   #2
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

I've been experimenting at home this evening, and I get the same result if I shoot anything on the "P" setting - properly exposed w/o flash, badly under-exposed with flash. But if I set the camera to either of the two fully automatic settings I get properly exposed flash pictures (still using the internal flash).

What on earth is going on?
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Old Apr 22, 2011, 1:56 AM   #3
Member
 
Join Date: May 2010
Location: Hawaii
Posts: 57
Default

Check you flash compensation setting in the event it has accidentally been set to a - number
diverdave is offline   Reply With Quote
Old Apr 22, 2011, 7:19 AM   #4
Senior Member
 
Join Date: May 2008
Location: Dickson, Tennessee
Posts: 461
Default

I would agree with Dave. Check to make sure you're flash exposure comp is not dialed down. Tried it on both of mine and it worked as it should.
shadokachr is offline   Reply With Quote
Old Apr 22, 2011, 7:27 AM   #5
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Quote:
Originally Posted by peterbj7 View Post
The flash is set to ETTL II and wireless is enabled
Are you sure that's not your entire problem (wireless is enabled)?

IOW, it may be trying to act as a commander to fire an off camera flash (via flash commands before the shutter is open) and not contributing anything to the actual exposure (since it's expecting an off camera flash to provide light for the exposure).

How about your distance? You may have been too far away for a built in flash to illuminate your subject. It's a relatively weak flash with a GN of 12 Meters / 39 Feet at ISO 100.

So, if you were using an aperture of around f/5.6, flash range would only be around 2.1 Meters (or around 7 feet) at ISO 100. Flash Range = GN/Aperture at ISO 100

If you had the aperture stopped down more, it would be even less unless you bumped up the ISO speed (each time you double the ISO speed, flash range increases by 1.4x).

But, my guess is that your problem is mostly caused because you have wireless enabled (it's probably trying to act as a commander and not contributing anything to the actual exposure).
JimC is offline   Reply With Quote
Old Apr 22, 2011, 10:38 AM   #6
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

Good point. I'll try it with wireless turned off. Distance is not an issue, nor is aperture. I've gone right through all the menus and I haven't found anything else to explain this, so it seems likely it is the wireless issue. I'll turn it off and try again. It's a bit silly though if that's the case. But as I said, in either of the two automatic settings the exposure is perfect, and I imagine that with those settings wireless is automatically disabled.

Well I've just tried it with wireless disabled and it was the answer! Exposure is now perfect. I'm going to have to remember that, as I'm finding myself alternating between the on-board flash and an off-camera flash, so I'll have to go into the menus each time I change.
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Old May 1, 2011, 12:27 PM   #7
Senior Member
 
Join Date: May 2008
Location: Dickson, Tennessee
Posts: 461
Default

It should work with wireless enabled or disabled.
shadokachr is offline   Reply With Quote
Old May 1, 2011, 4:01 PM   #8
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

I now understand what's happening, and when wireless is enabled the on-board flash is treated just as a fill-in. It seems strange that a picture can be perfectly exposed without the onboard flash, but switch it on (when wireless is enabled) and the picture is severely under-exposed. But there it is. With wireless disabled the on-board flash does exactly what I wanted it to do - fill in without upsetting the exposure.
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Old May 1, 2011, 4:29 PM   #9
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,545
Default

Quote:
Originally Posted by JimC View Post
Are you sure that's not your entire problem (wireless is enabled)?

IOW, it may be trying to act as a commander to fire an off camera flash (via flash commands before the shutter is open) and not contributing anything to the actual exposure (since it's expecting an off camera flash to provide light for the exposure)...

... But, my guess is that your problem is mostly caused because you have wireless enabled (it's probably trying to act as a commander and not contributing anything to the actual exposure).
JimC is correct! When you're in wireless mode the on board flash only emits control signals to other wireless flash(es) which will contribute to the exact amount of lighting...

Try to turn on your external slave (Di866 ?), the slave flash will then perform the fill correctly!
-> Think about it, if the on-board flash did actually have to do the fill, it's cap might be discharged enough that it might not have enough juice left to issue the control signals to the slaves.

This work the same on the Sony or Nikon when the on-board flash is selected as the controller (Master)
__________________
photos (ϕοτοσ), light
graphos (γραϕος), painting

Last edited by NHL; May 2, 2011 at 5:48 AM.
NHL is online now   Reply With Quote
Old May 1, 2011, 7:08 PM   #10
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

Yes. I'm not sure it's totally logical - after all the flash does go off, but at low intensity, and the camera seems to stop down much more than the actual flash warrants. But I know how to make it work and it's good then. So quirky or not I'll put up with it.
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:19 PM.