Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Mar 12, 2012, 10:20 AM   #1
Junior Member
 
Join Date: Mar 2012
Posts: 5
Default old Sigma 28-80 Macro with new T1i?

Hi -

I bought a used Sigma 28-80 Macro EF lens, and I'm trying to use it on my 2 year old T1i.

I get a communication error every time. (with the silly "clean the contacts" suggestion).

Is this lens too old to work with a digital? Any way to get it updated to communicate with my T1i?


Thanks for your help!

Holly


Update: I contacted Sigma, and they told me my lens is too old to be updated. They offered me a discount on a new lens 17-70 mm F2.8-4 DC OS HSM for $365. That's about $120 off the Amazon price.

Update: the lens sometimes works and sometimes doesn't... I probably won't bother with it because I don't like the idea of missing a shot unexpectedly. Looks like it will be re-donated to Goodwill for someone who is still shooting film!

Last edited by HollyG; Mar 12, 2012 at 2:54 PM. Reason: adding updated information
HollyG is offline   Reply With Quote
Sponsored Links
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:33 PM.