Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Aug 16, 2012, 9:51 PM   #1
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default Magic Lantern v.2.3 firmware for 5DMKII, 50D, 60D. 500D, 550D and 600D

I saw a posting on fredmiranda.com with free Magic Lantern V.2.3 firmware download for Canon DSLRs listed above. Has anyone try it?
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Sponsored Links
Old Aug 17, 2012, 1:05 PM   #2
Senior Member
 
WCKSer's Avatar
 
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,857
Default Update

I have just installed it in my 5DMKII. It is very easy just unzip the files onto your CF card according to the installation instruction and reboot. The firmware is really an add-on and does not modify the Canon firmware and can be uninstalled if you don't like it. It will not void your warranty according to the instruction manual.

There is a lot of enhancement features for video shooting. The best of all for shooting stills is the HDR bracketing for the 5DMKII. Also the focusing enhancement is cool too. There is a lot of thing in there, I need to spend some time to go through everything to see what I can use.

Is there anyone out there have done it or brave enough to try it?
__________________
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Aug 30, 2012, 5:28 PM   #3
Junior Member
 
Join Date: Sep 2006
Location: Whitefish, MT
Posts: 16
Default

I tried it on my 60D, it has some cool stuff. I uninstalled it after my camera starting acting weird, screen was artifacting and I would get a constant HD light when I shut the camera off
__________________
Fuji X100s
Rick67 is offline   Reply With Quote
Old Oct 14, 2012, 9:35 AM   #4
Senior Member
 
TD Cole's Avatar
 
Join Date: Jan 2005
Posts: 1,493
Default

@ Rick, I had the same problem but format my card and reinstalled and it worked flawlessly after.
__________________
Gripped Canon 7D and some glass
Flickr
FotoZone Facebook Group
TD Cole is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:31 AM.