Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 11, 2004, 9:04 AM   #1
Junior Member
 
Join Date: Jan 2004
Posts: 8
Default

Hey everyone, hope you can help…



I am from the UK, and bought a battery grip for my 300D in the US the other week. I am really happy with the way it has changed the shape of my camera making it so much easier to use…BUT I am having a problem with the battery display. I can put in two fully charged batteries and after about 5 mins or so of shooting (either with or without the review mode) the battery symbol goes down to almost empty. This happens every time I use the battery grip but when I put a single charged battery in the camera it takes hundreds of pics before the same symbol appears.



I have continued to take pics with the battery symbol on almost empty which leads me to believe that it is just an error but I don't want to be in a position where I run out of battery during a shoot….



Has anyone come across this problem themselves? Any help/advice would be gratefully received.



Thanks



Mark :?
sniperonline is offline   Reply With Quote
Sponsored Links
Old Oct 11, 2004, 11:39 AM   #2
Senior Member
 
choeschen's Avatar
 
Join Date: Mar 2004
Posts: 332
Default

I also have the battery grip with my 300D and had no issue like this. Have you removed and reinstalled the grip and the batteries? Also try cleaning the contacts on the grip and batteries and see if that helps. If none of the above help try to exchange the grip for another one.
choeschen is offline   Reply With Quote
Old Oct 13, 2004, 5:15 AM   #3
Junior Member
 
Join Date: Jan 2004
Posts: 8
Default

Thanks for the reply, will give it a go this weekend and see what happens!

Thanks


sniperonline is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:04 AM.