Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 31, 2002, 1:02 PM   #1
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default D60 died after about 100 shots....

My brand new D60 died after 100 shots. The back LCD does not come on, but when I hook it up to my PC it tells me that camera is busy or the LCD should be turned off.

Pictures can be taken, but only one at a time. Power has to be switch off before the next picture can be shot. LCD works fine after the shot and shows the picture with info. Only every other picture is written on my Microdrive.

Also when I switch D60 on, the lens starts focusing. In other words it is turning from close-up to infinity and stops after few tries.

Microdrive is readable via PC Card adapter on a laptop.


Anybody had any similar problems?
Pforsgar is offline   Reply With Quote
Sponsored Links
Old Nov 1, 2002, 9:07 AM   #2
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default Battery grip was the problem

Works fine without it. It is being repaired. Interesting to see how long it takes.....
Pforsgar is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:41 PM.