Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Mar 11, 2005, 7:41 PM   #11
Member
 
Join Date: Feb 2005
Posts: 65
Default

My husband just picked mine up from our local camera store. I was on a waiting list and they called today and said they got only 4 in.

I went with the kit lens and 1GB memory card. I can't wait to get the battery charged.
stonehill is offline   Reply With Quote
Old Mar 11, 2005, 8:15 PM   #12
Member
 
Join Date: Jul 2002
Posts: 63
Default

Come on folks, lets see some more XT photos!!! :|
Bilbo99 is offline   Reply With Quote
Old Mar 11, 2005, 8:15 PM   #13
Member
 
Join Date: Jul 2002
Posts: 63
Default

Come on folks, lets see some more XT photos!!! :|
Bilbo99 is offline   Reply With Quote
Old Mar 12, 2005, 8:59 AM   #14
Member
 
Join Date: Jun 2004
Posts: 65
Default

I bought one at my local Best Buy. They were flying off the shelves. Nice feel in the hand AFTER I put on the battery and lens. I didn't care for it too much on the display stand without lens and battery.

I do like the smaller size now vs. the 300D or 20D. I was seriously considering the 20D but it just felt too big for the kind of shooting I wanted to do. I am in the process of getting used to the camera and taking a few shots with it. So many things to tweak that it is going to be a while to get a handle on what works best.

So far I am loving it though. I do need to find a good lens for telephoto work.
Wavshrdr is offline   Reply With Quote
Old Mar 13, 2005, 1:05 AM   #15
Junior Member
 
Join Date: Mar 2005
Posts: 28
Default

I have it, bought it at fry's. Its vry small and very quiet compared to the 20D. I ran around taking photos and......... downloaded the photos and found 2 things... The sigma 17-35 HSM lens is worse than the kit lens wide open, more testing will be done this weekend and... I have 1 bad pixel. Dam it!! I will shoot with it this week and return it on Thurs. when the new shipment comes in. Anybody have any shot comparing it with the Rebel 300 or 20D???
epocenter is offline   Reply With Quote
Old Mar 14, 2005, 1:24 AM   #16
Junior Member
 
Join Date: Mar 2005
Posts: 28
Default

Shot about 200 shots today..... This camera is awsome, really quiet, I was able to track motorcycles coming around a corner going about 20-30 mph with good success using the 70-300 DO lens usingrapid fire and panning IS. Success rate of about 70% or better. I am returning the Sigma Lens, not sharp enough. One really strange thing happened, I took about 20 shots with the 28-135 IS lens and it showed an error after every shot, when i got home I noticed none of them wrote to the card..... Has anyone else had this problem or is my lens dead????



I am new to this forum if someone tells me how to post a photo, I will throw a couple up....
epocenter is offline   Reply With Quote
Old Mar 14, 2005, 8:12 AM   #17
Senior Member
 
bmullen@comcast's Avatar
 
Join Date: Oct 2004
Location: Pennsylvania
Posts: 4,435
Default

this should help

http://www.stevesforums.com/forums/v...amp;forum_id=9
bmullen@comcast is offline   Reply With Quote
Old Mar 14, 2005, 1:36 PM   #18
Junior Member
 
Join Date: Mar 2005
Posts: 28
Default

Thanks Ill give it a shot (posting photos)when i get back I am going out of town for a couple days. I returned my sigma 17-35 and bought the Canon 17-40 L , I sould get it later this week.
epocenter is offline   Reply With Quote
Old Mar 15, 2005, 11:14 PM   #19
Member
 
Join Date: Dec 2004
Posts: 75
Default

Just got mine this afternoon. Have been shooting everything that moves to test it out. At this point my feelings are bittersweet.
So far I like the features and performance but I hate the asthetics. Too small and too light. Shooting with the Canon 28-135 IS I notice that the camera body doesn't have enough weight/mass to offset my hand turning the zoom ring thus causing a slight jitter when I start the motion.(Never felt this on the 300D)
I realize that I would rarely shoot while actively zooming in or out but just the fact that the motion is less than fluid really bothers me.
Also while I am being so critical, the shutter sound is ridiculous. Sounds like some kind of space toy.
Sure wish Canon had kept the same body and upgraded the internals.
I guess I should buy a 20D and stop complaining

Will try to post some pics soon, catching the red eye in the morning so it will most likely be tomorrow before I get a chance.

I didn't get any errors using the 28-135 (epocenter)
davedeal is offline   Reply With Quote
Old Mar 19, 2005, 12:30 AM   #20
Junior Member
 
Join Date: Mar 2005
Posts: 28
Default

I returned the first XT with bad pixel and now have the replacment. This was taken with the first XT using the canon 70-300 DO IS in panning mode. The bike was only going about 25mph.... Still the auto focus perormed really well in servo.....
Attached Images
 
epocenter is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:23 AM.