Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Aug 9, 2005, 2:06 PM   #1
Junior Member
 
Join Date: Jul 2005
Posts: 21
Default

Hey guys,

The drivers link on canonusa.com appears to be broken. Any of you have the drivers for it? I would think XP would detect it as any other flash drive, but apparently it's not that easy.

Thanks for your help.
Ronnell is offline   Reply With Quote
Sponsored Links
Old Aug 9, 2005, 8:58 PM   #2
Senior Member
 
Join Date: Jan 2005
Posts: 301
Default

I just checked and the driver downloadlinks for the XTare working fine. Maybe the site was down when you tried.



Bob
BobA is offline   Reply With Quote
Old Aug 10, 2005, 7:09 AM   #3
Junior Member
 
Join Date: Jul 2005
Posts: 21
Default

Is this the link you go to? : http://consumer.usa.canon.com/ir/con...;modelid=11154




Ronnell is offline   Reply With Quote
Old Aug 10, 2005, 11:41 PM   #4
Senior Member
 
Join Date: Jan 2005
Posts: 301
Default

Just tried the one you displayed and it works fine ... took me to the Rebel XT download library. All the links on that page also work, as well as the actual download links.

If it's not working for you, it's a problem at your end. Maybe you need to clear your browser cache.



Bob
BobA is offline   Reply With Quote
Old Aug 14, 2005, 4:34 PM   #5
Junior Member
 
Join Date: Jul 2005
Posts: 21
Default

BobA, thanks for checkin. Turned out to be firewall related. Disabled it temporarily -- bam, downloaded fine.


Ronnell is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:26 PM.