Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Nov 1, 2005, 7:58 PM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 20
Default

I own a Canon XT. I am new to using a DSLR, and recently I've begin to use P mode more often, but one thing I have noticed is that when the XT is in P mode, you don't really see any focus points light up. Is it suppose to be like that? or is it suppose to be like in full auto mode where focus points will light up? It really bothered me because the camera is focusing on the background instead of the subject . One last thing, usuallylens will focus, but from time to time, the lens just won't focus, yet I can still take pictures in P mode. Can anyone help me explain what I am doing wrong? and explain about the focus mode in both P mode and full auto mode. Thanks!!
b00st4ddicted is offline   Reply With Quote
Sponsored Links
Old Nov 2, 2005, 5:30 AM   #2
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

This has more to do with the AF mode selection than P or the other 'Auto' mode.

The AF point will not light up when you're in AI-servo, which you can select in the P-mode. The AF point(s) will only light up in single-shot AF. In AI-focus, which is a combination of the two, the camera starts with single-shot AF(you can see the red LED), and automatically switch to AI-servo(you can not see the red LED).

See page 152 of the manual - Except for the Sport mode (red AF LED off) the AF is set to single-shot AF (red AF LED light up) automatically for you in all other modes in the Basic zone.

-> In the P mode you have to set the camera to single-shot AF (or AI-focus), the red AF indicator will not light up in AI-servo AF
NHL is offline   Reply With Quote
Old Nov 2, 2005, 9:59 AM   #3
Junior Member
 
Join Date: Sep 2004
Posts: 20
Default

thank you sooo much!! that solved so much problem for me
b00st4ddicted is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:33 AM.