Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Dec 21, 2005, 8:14 PM   #1
Member
 
Join Date: Aug 2005
Posts: 47
Default

I have a 20D, bought it about 3 months ago and suddenly the flash won't pop up. When I push the flash button, I hear 3 clicks like it wants to pop up bot cannot then I get an error 05 on the screen. Any idea how to resolve this issue or am I forced to take it in for repair.

Steve


torresmd is offline   Reply With Quote
Sponsored Links
Old Dec 23, 2005, 10:48 AM   #2
Member
 
alan sh's Avatar
 
Join Date: Feb 2004
Posts: 76
Default

Mine does this occasionally. Try tipping it backwards then press the button. Also, try pulling it up manually as you press the button (gently).

Once open, try cleaning all the edges you see.

If all this doesn't work, take it in for repair or buy an external flash (may be cheaper)

Alan
alan sh is offline   Reply With Quote
Old Dec 23, 2005, 5:59 PM   #3
Member
 
Join Date: Aug 2005
Posts: 47
Default

I finally got the flash to pop up by gently pulling up and pushing the button at the same time. I cleaned it all edges, inspected everything all looked good, closed it and sure enough it is stuck again. I guess I need to buy a real flash now.
torresmd is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:09 AM.