Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Jan 22, 2006, 7:25 PM   #1
Junior Member
 
Join Date: Oct 2005
Posts: 7
Default

Hello all.

Just a quick question regarding this camera with Sigma lenses. My lens (28mm f1.8 )in unsuitable to be upgradable (from Sigma) and I wanted to know if anyone has used Sigma lenses in manual mode to get around the ERR99 problems? I have heard that some can be used in aperture priority mode where the lens's widest setting without problems - is this true?

If so can the auto focus be used also?

Thanks in advance.

Cheers Paul
Mrjoshua822 is offline   Reply With Quote
Sponsored Links
Old Jan 28, 2006, 11:37 PM   #2
Member
 
Join Date: Jan 2006
Posts: 64
Default

I have a 75-300 (film)sigma on my 350d and get the same error msg.

I just got the camera so I haven't had time to play with it, but I did drop it into the sport mode and it worked. Let me know if you find out anything.

bg
picturethis62 is offline   Reply With Quote
Old Jan 29, 2006, 10:42 PM   #3
Junior Member
 
Join Date: Oct 2005
Posts: 7
Default

Hi BG

I'm assuming that in sports mode the camera is after the fastest shutter speed and hence the widest aperture -often this is the maximum in a zoom lens under usual conditions.

This might back up my theory where these lenses can be used "wide open" on the 350D as the camera uses the default maximum aperture for the particular lens. I'm assuming that the camera recieves some sort of reference from the lens regarding the aperture setting so it may be ignored (ie zero feedback) when the lens is wide open.

My camera arrives tomorrow so all will be revealled andI can only pray that my 28mm is OK wide open :-)

Cheers Paul

Mrjoshua822 is offline   Reply With Quote
Old Jan 30, 2006, 8:09 PM   #4
Junior Member
 
Join Date: Oct 2005
Posts: 7
Default

Well, I tried the Sigma lens on the 350D and it works fine in manual and auto focus as long as the aperture remains @ 1.8 (wide open). Anything else and I get the error message. So, using it in aperure priority is fine

Cheers Paul
Mrjoshua822 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:36 PM.