Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old May 26, 2006, 8:24 AM   #1
Member
 
Join Date: Feb 2004
Posts: 46
Default

My BG-E2 Battery Grip for the 30D has a .4 voltage drop with a single BP511 installed in the "right side" of the grip! When I install the battery in the "left side", the grip's output terminal strips shows the full voltage with no loss!!

With the BG on the 30D, My new 511's appear not to be holding up when installed in the right side of the grip, only getting 300 shots (no flash) before the 30D shows a mid-battery charge(battery measures 7.8 volts), and is depleted before 400 or so shots (battery under 7.8 volts)!

Can Anyone here confirm with a volt meter if your BG-E2 has this voltage drop with a single 511 installed in the right bank???

Canon states ther should be "no difference" between the right\left banks for a single BP511 usage, they should be equal to the voltage of the battery installed! They want it in to check-out! Thought I could get some feedback first before sending it off to Canon!

Appreciate any help and input!!

Ted
theophile is offline   Reply With Quote
Sponsored Links
Old May 28, 2006, 7:18 AM   #2
Member
 
Join Date: Feb 2004
Posts: 46
Default

Can Anyone confirm a .4 voltage drop in the BG-E2 battery grip Output when using a single BP511 in the Right bank, and an Equal voltage in the output when installed in the left bank???
theophile is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:59 PM.