Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon Lenses

Reply
 
Thread Tools Search this Thread
Old Aug 15, 2008, 12:45 PM   #1
Senior Member
 
Join Date: May 2005
Posts: 429
Default

I have UV filters on all my lenses to protect them and I noticed recently that my 300mm lens picked up a lot of glare recently. I took of the UV filter and it was a bit foggy(not moisture). I left it in the car for a short time and it was hot and humid, could that have causethe problem? What can I use to clean it? I have heard that you just dont want to use the shirt tail because of scratches? What about cleaning the lens? What do I do there? Do I just need to replace the filter with a new one? What is the best in a cheap price range if I do have to replace it.

Thanks ahead of time for the help.

I use a Canon 20D and several lenses.
RP33 is offline   Reply With Quote
Sponsored Links
Old Aug 22, 2008, 9:12 PM   #2
Senior Member
 
Michi's Avatar
 
Join Date: Jul 2003
Posts: 176
Default

Here a link you might find interesting:

http://www.bobatkins.com/photography..._cleaning.html


Michi is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:17 AM.