Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon Lenses

Reply
 
Thread Tools Search this Thread
Old Jan 9, 2005, 8:36 PM   #1
Member
 
Join Date: Dec 2004
Posts: 75
Default

Hello everyone,
Santa brought me a new Digital Rebel for Christmas

However when I try to use it with a lenses I already have I get an error 99.

The lenses is from my old film rebel and is a sigma 28-80. It worked fine for about 10-15 shots but now everytime I shoot I get the error 99. Any ideas?
davedeal is offline   Reply With Quote
Sponsored Links
Old Jan 10, 2005, 6:20 AM   #2
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

Error 99 is a general fault not necessary caused by a lens - although mounting and unmounting a lens sometime causes this... Did you try to recharge the battery? Extra current consumption from an older lens can be a source of this too.

Older Sigma lenses madebefore year2000 could have a compatibility problem and Sigma used to retofit for free - Did you check with them? Newer lenses and especially EX lenses with HSM are fully compatible
NHL is offline   Reply With Quote
Old Jan 10, 2005, 10:10 AM   #3
Member
 
Join Date: Dec 2004
Posts: 75
Default

Hmm...
The battery was fully charged. The lens is an older model. In fact I just had it "repaired" by sigma because the original one stopped working. Thanks for the help, I will contact Sigma about compatability.
davedeal is offline   Reply With Quote
Old Jan 10, 2005, 10:48 AM   #4
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

Several Drebel users of the same lens here: http://www.pbase.com/cameras/sigma/2880_35_hf
... and over here too: http://www.photosig.com/go/photos/browse?id=17184
NHL is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:33 AM.