Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Oct 6, 2006, 9:56 PM   #1
Junior Member
 
Join Date: Oct 2006
Posts: 2
Default

Just recieved a new a630. Fresh from the box it gives me the "No Memory Card" message. Same result with both the small card that came with the camera and the 1g Sandisk I bought. I bought this to replace my a70 which gave me the e18 error. I read all the bad stuff about e18 through a google search but stuck with Canon anyway. Bad decision. The camera is going back I will not be buying Canon in the future.
jjb45 is offline   Reply With Quote
Sponsored Links
Old Oct 7, 2006, 1:44 AM   #2
Senior Member
 
Join Date: Jul 2006
Posts: 260
Default

I looked at other forums and haven't been able to the find the "no memory card" error as prevalent, but the A70 was a horrible camera. Everytime I heard someone say their Canon broke it was always an A70. Do a search by the model numbers and you'll find that your old one was a rare crap camera from Canon. Look up the A630 forums and take a look for error problems.
KALEL33 is offline   Reply With Quote
Old Oct 7, 2006, 10:48 AM   #3
Junior Member
 
Join Date: Oct 2006
Posts: 2
Default

I hope you are correct as I will likely have to exchange the a630 or pay a restocking charge. However, if the a70 is such a widely known dog, shouldn't Canon acknowledge that and do something about it?
jjb45 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:12 PM.