Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jun 12, 2003, 6:50 AM   #1
Junior Member
 
Join Date: Jun 2003
Posts: 3
Default A70 problem : power button blocked

When I tried to turn on my camera yesterday, the power button didn't want to move. It is blocked as if it has been pushed.
The A70 don't want to turn on, now.
Does (did) anyone have the same problem ?
livevil is offline   Reply With Quote
Sponsored Links
Old Jun 12, 2003, 7:09 AM   #2
Fly
Member
 
Join Date: Jun 2003
Posts: 44
Default

I had the same problem once, but found out, that it was just the batteries that needed to be replaced........
Just checking, to rule out that possibility!

Good luck!
Fly is offline   Reply With Quote
Old Jun 12, 2003, 7:14 AM   #3
Junior Member
 
Join Date: Jun 2003
Posts: 3
Default

This is not because of the batteries. I've already checked that and tried another set.
The button seems to be in the "pushed" position.
livevil is offline   Reply With Quote
Old Jun 12, 2003, 7:38 AM   #4
Junior Member
 
Join Date: Jun 2003
Posts: 5
Default wiggle wiggle

Im sure you tried already, but try wiggling the button by rubbing over it. another thing you can try, maybe use a piece of good tape and stick it on the button, then try to pull the button up? If it moves, it does mean the switch itself might be broken?!
togt is offline   Reply With Quote
Old Jun 12, 2003, 8:07 AM   #5
Junior Member
 
Join Date: Jun 2003
Posts: 3
Default

I've already tried that and the switch is maybe broken because the button can move a little.
But I can't understand how it happened. I take care of my camera and moreover, the button is a little bit protected by the shaź of the camera. Only a direct push could have done that
livevil is offline   Reply With Quote
Old Jun 13, 2003, 2:22 AM   #6
Senior Member
 
Join Date: Apr 2003
Posts: 282
Default

I had a similar problem, but I don't think the button was "pressed in" just the cam wouldn't switch on - took it back to the shop and got it exchanged (only had it 8 days at the time)

Stef
stefank is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:51 PM.