Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jun 26, 2003, 7:16 PM   #1
Junior Member
 
Join Date: Jun 2003
Posts: 1
Default Canon S50 and memory card error

Using an S50 and a 512MB Simpletech CF card I keep getting memory card errors. It doesn't happen all the time, it seems to happen when I try to take a couple of pictures in quick succession. I reduced the resolution, and I have reformated the card in the camera to no avail. Is this normal, or is there a problem with the card? Is there anyway to check for errors on the card?
jamesh is offline   Reply With Quote
Sponsored Links
Old Jun 27, 2003, 2:49 PM   #2
Junior Member
 
Join Date: Jun 2003
Posts: 4
Default

Hi, I think that the problem could be the CF Simpletech, you said that the error appear when you try to get a couple of pictures in few time. The Simpletech ( the others too) have a time of recording that used to save the imeges, the time is about 2.50 seconds, if you do a cupple in few times the card could have problem in during the recording. What you could do is try to change the card in the store where you have bought it and if possible try another type of CF.
giambosuperstar is offline   Reply With Quote
Old Apr 17, 2005, 12:07 AM   #3
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

If you're getting memory card error with a Canon S50 and have reformatted the card with the same error message. Try another memory card. If that doesn't work, look at the bottom of the memory card slot, you probably bent one or more of the contactor pins. Use a small screwdriver and very, very carefully straigten out the pin and put the memory card back in. That should do the trick. From now on, use a USB cable to download your photos, don't pull the card out anymore as the pin is probably weaker than before and can break. Then you'll be in real trouble.
PYoung2493 is offline   Reply With Quote
Old Aug 25, 2005, 6:44 PM   #4
Junior Member
 
Join Date: Aug 2005
Posts: 1
Default

I have a Canon s45 that after a year or two came up with two pins in the middle of the CF card outer row bending towards each other. The camera stopped working. Rather than wreck the camera with my mechanics, I sent it back to Canon for repair. They wanted $158 to fix it. I opted for the $280 (including shipping) refurbished upgrade to an s70. I returned their estimate email requesting answer to the question I asked them in the letter I sent with the camera. How could two pins in the middle of the CF socket get bent without bending the others? Even if one could shove the card in backwards, the holes appear to be symetrical. If I ever get an answer I'll post it here.
miltko is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:17 PM.