Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Dec 23, 2009, 6:06 AM   #1
Junior Member
 
Join Date: Dec 2009
Location: Zamboanga City, Philippines
Posts: 4
Default PowerShot S5 IS: screen problem

hello buddies, i need help., i have a problem with my friend's Canon PowerShot S5 IS, the problem here is the screen, it only stay's black..,but the menus and icons or should i say, GUI are ok. maybe a problem with the lens
sirnyor is offline   Reply With Quote
Sponsored Links
Old Dec 23, 2009, 6:43 AM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Do you see an image in the EVF? If you press the display button does it change anything?

If not, it sounds like the main imaging sensor may be bad (or one of the supporting components failed, or you have a cracked circuit board, or some other problem preventing the signal to be used from the main imaging sensor).

That's speculation. But, if the LCD works fine for menus, but can't display a signal from the main imaging sensor, you probably have a serious issue with the camera that will most likely require a trip back to Canon to fix.
JimC is offline   Reply With Quote
Old Dec 23, 2009, 6:59 AM   #3
Junior Member
 
Join Date: Dec 2009
Location: Zamboanga City, Philippines
Posts: 4
Default

@ JimC

sir, can i do that by myself? is it safe to open? or is there a guide that can fix myself, otherwise i repair a cellular phone also..,anyways, thank you for the help sir..,
sirnyor is offline   Reply With Quote
Old Dec 23, 2009, 7:06 AM   #4
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

I would not suggest trying to repair it yourself (and I'm unaware of any service manuals that are available to the public for them, although Canon has them for internal use). But, even if you had a service manual, you'd still need the correct test equipment, parts, etc. So, I'd suggest sending it back to Canon for repair.
JimC is offline   Reply With Quote
Old Dec 23, 2009, 7:20 AM   #5
Junior Member
 
Join Date: Dec 2009
Location: Zamboanga City, Philippines
Posts: 4
Default

thank you very much sir..,well i guess i have to return to the owner to avoid further damage.. , anyways sir, advance merry Christmas and a happy new year
sirnyor is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:36 AM.