Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Apr 22, 2010, 9:38 PM   #1
Junior Member
 
William Richard's Avatar
 
Join Date: Nov 2009
Posts: 12
Default Canon mount issue - video

http://tinyurl.com/y4wcqjy

The body/lens mount locked but does not seat properly. The mount play/wiggle/movement is unacceptable. And more apparent when lens is secured to a tripod. I have an old ('73) Nikon F2 and all lens mount snug without any play.

Last edited by William Richard; Apr 22, 2010 at 10:00 PM. Reason: text addition
William Richard is offline   Reply With Quote
Sponsored Links
Old Apr 22, 2010, 11:10 PM   #2
Senior Member
 
Hawgwild's Avatar
 
Join Date: Mar 2006
Location: Pensacola, Florida
Posts: 3,525
Default

Wow, never seen that before. Does another lens mate up properly? I would hate to think the lens's mount is defective, especially one of that quality (and price!).
__________________
Always use tasteful words - you may have to eat them.
You cannot find knowledge by rearranging your ignorance.

My Flickr
-Robert-


Hawgwild is offline   Reply With Quote
Old Apr 23, 2010, 1:41 PM   #3
Junior Member
 
William Richard's Avatar
 
Join Date: Nov 2009
Posts: 12
Default

Quote:
Originally Posted by Hawgwild View Post
Wow, never seen that before. Does another lens mate up properly? I would hate to think the lens's mount is defective, especially one of that quality (and price!).
Thanks Hawgwild. My thoughts exactly on the lens mount but as this 7d was my very first purchase of a DSLR that one lens was it. Not knowing whether the defect was with the body or lens both were returned for an exchange.

I'd been following tech and forum reviews on the 7d since its launch knowing they'd catch if it was a deal or no deal. It seemed the green light was given. Then again nothing in all this research produced an inkling that the 7d (nor the new 70-200 2.8 L IS II) may have issue(s) with the mount not seating properly. Who would've thought: Ask about the mount dummy! Thanks Murphy.

On a brighter note (excepting the mount issue) the 7d and lens did function, and from what I could gather from test shooting, working the menu, AF aspects, etc., I could easily grow to enjoy this product.
William Richard is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:55 PM.