Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Sep 4, 2004, 10:20 PM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 11
Default

:?Unable to get my New Camera's flash to open, have followed the book, camera will flash on taking a shot, but the flash houseing does not open automatically. Is the flash supposed to pop up on it's own? or do you manually lift it up? Any help is appreciated, the flashbutton on the side of the camera does nothing. Possibly I was sent a defective unit. Thanks for any help offered.
steve sr is offline   Reply With Quote
Sponsored Links
Old Sep 5, 2004, 3:14 AM   #2
Member
 
judell74's Avatar
 
Join Date: Aug 2004
Posts: 78
Default

Hi steve! and welcome to steve's forum!

The S1 IS flash pops-up AUTOMATICALLY! So, that's means you dont have to open it manually or else you might broke your new digicam!

Maybe your flash mode is turned off. To check this, look on your LCD screen and find the ARROW icon pointing downwards. Set it to Auto Mode so that it will pop-up when your digicam needs it.
judell74 is offline   Reply With Quote
Old Sep 5, 2004, 6:35 AM   #3
Junior Member
 
Join Date: Sep 2004
Posts: 11
Default

Thanks Judell, I have it set on auto move and the flash set for on, but the flash hood does not pop up. I'll be returning it for an exchange. Great site! I am sure I will be back once I get a working camera.
steve sr is offline   Reply With Quote
Old Sep 11, 2004, 12:31 AM   #4
Junior Member
 
Join Date: Sep 2004
Posts: 5
Default

I have the same operational problem too. :?
tom_handheld is offline   Reply With Quote
Old Sep 11, 2004, 2:18 AM   #5
Member
 
judell74's Avatar
 
Join Date: Aug 2004
Posts: 78
Default

steve sr wrote:
Quote:
Thanks Judell, I have it set on auto move and the flash set for on, but the flash hood does not pop up. I'll be returning it for an exchange. Great site! I am sure I will be back once I get a working camera.
Yeah! Just return it. Maybe you got a defective product.
judell74 is offline   Reply With Quote
Old Mar 7, 2005, 8:42 AM   #6
Junior Member
 
Join Date: Mar 2005
Posts: 1
Default

I recently purchased an S1 IS and had the exact same problem with the flash not popping up correctly, but I found the problem on mine. When the flash "clicked" as many of you have observed, the release mechanism fails to 'let go' of the flash, which is sprung. On mine, I forced the flash open (this is probably not recommended, but I did it at least 10 times without breaking or bending any parts). To make a long story short, if you look under the flash (left side as you're facing the flash), you will see a black catch mechanism held on by one small Phillips screw. When I removed this screw and pulled the catch off, there was a very small washer in between the catch and the flash plastic housing....this appears to be an assembly error. I reassembled the catch with the washer on the screw-side of the catch, and this fixed the problem completely. Again, the reassembly is Catch-Washer-Screw, NOT Washer-Catch-Screw. Hopefully this helps everyone out having this problem.


Scott
fisher112 is offline   Reply With Quote
Old Mar 24, 2005, 1:28 AM   #7
Junior Member
 
Join Date: Mar 2005
Posts: 1
Default

Awesome!

After using my S1 for about 7 months, the flash just stuck on me yesterday. I followed the advice of your post and it worked like a charm! It really saved me the nosebleed of trying to get someone to fix it while not having a camera for a while.

Thanks a lot for the post!
tkj256 is offline   Reply With Quote
Old Mar 24, 2005, 6:32 PM   #8
Senior Member
 
Join Date: Nov 2004
Posts: 935
Default

That's kind of scary ... to have assembly error like that. Makes you wonder about quality control...especially when a whole bunch of camera models (not just canon) are flawed before they even leave the factory.
Kenny_Leong is offline   Reply With Quote
Old Mar 24, 2005, 7:15 PM   #9
Senior Member
 
mrcoons's Avatar
 
Join Date: Oct 2004
Posts: 119
Default

Thanks Scott! I've never had a problem with my S1 (after over 2000 photos) but it's nice to know where to look if it does happen!



Mark
mrcoons is offline   Reply With Quote
Old Apr 6, 2005, 8:49 AM   #10
Junior Member
 
Join Date: Apr 2005
Posts: 1
Default

Before I try your fix, how much force do you have to apply to open the flash? I don't want to trash the thing by going Mr. Incredible on it. This is the second time this has happend. I had it 'fixed' under warranty the first time but I think I'm just out of warranty now.

Thanks.
izoomzoom is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:04 AM.