Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Sep 14, 2004, 9:03 PM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 2
Default

I've had a Canon S330 for a couple years now and its worked great. But just recently I can't seem to power it up. When I press the ON button, the power light and display comes on for a split second, butthen just immediately turns off. If I fully chargethe battery, the camera powers up for a little bit longer, but once again turns off within 2 seconds at most. I have tried 2 different batteries and the same thing happens.

It seems like either the camera isn't getting enough juice from the battery, or the battery becomes immediately discharged, or perhaps something else altogether.

Any ideas would be very much appreciated. Thanks.
apaschyn is offline   Reply With Quote
Sponsored Links
Old Sep 18, 2004, 10:31 AM   #2
Member
 
judell74's Avatar
 
Join Date: Aug 2004
Posts: 78
Default

Have you tried on Alkaline Batteries?
judell74 is offline   Reply With Quote
Old Sep 22, 2004, 8:57 PM   #3
Junior Member
 
Join Date: Sep 2004
Posts: 2
Default

The camera does not take alkaline batteries.

It's the oddest thing, when I fully charge the battery the camera will work for about two seconds, then goes dead. If I try to turn it onagain, the Green on light will flicker on for a split second, then just go off.

I'm confused. Again, any advice or comments would be quite helpful. Thanks.
apaschyn is offline   Reply With Quote
Old Sep 23, 2004, 11:14 AM   #4
Member
 
judell74's Avatar
 
Join Date: Aug 2004
Posts: 78
Default

Ohhh sorry!:?I forgot that the S330 uses only lithium batts!

Maybe thats a sign of aDEAD battery!
judell74 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:38 PM.