Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Mar 7, 2005, 12:17 PM   #1
Junior Member
 
Join Date: Mar 2005
Posts: 2
Default

All of a sudden, my G3 started taking really bad images. Red, extremely grainy, overexposed. Changing settings hasn't helped. Here are a couple of examples. Any ideas? I'm going to try and reload the firmware tonight. Are there any other ways of purging or resetting the firmware?

http://www.rodriguezcadservices.com/...6/IMG_0011.JPG

http://www.rodriguezcadservices.com/...6/IMG_0012.JPG

Thanks for any help.
rafaelaustin is offline   Reply With Quote
Sponsored Links
Old Mar 7, 2005, 10:15 PM   #2
Senior Member
 
Join Date: Nov 2004
Posts: 145
Default

i dont know about resetting to the origional firmwar, but you can try leaving the battery out for an extended period of time and that should reset the camera to factory settings
lemondster is offline   Reply With Quote
Old Mar 7, 2005, 11:51 PM   #3
Senior Member
 
Join Date: Nov 2004
Posts: 935
Default

There's probably no reason for anything in the firmware to change right? Looks like the camera needs to go in for repairs.
Kenny_Leong is offline   Reply With Quote
Old Mar 9, 2005, 12:45 PM   #4
Junior Member
 
Join Date: Mar 2005
Posts: 2
Default

Took camera to shop and they said it was the imager and could be repaired by Canon for a flat rate of $182. It'll take 4-6 weeks for the repairs.
rafaelaustin is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:56 AM.