Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Nov 23, 2006, 8:29 PM   #131
Junior Member
 
Join Date: Nov 2006
Posts: 1
Default

i had the same problem with my canon and am still working. who should i ask to send me a new card? should i e-mail canon?
nerdsageek is offline   Reply With Quote
Old Dec 4, 2006, 2:40 PM   #132
Junior Member
 
Join Date: Nov 2006
Posts: 20
Default

My friend just bought a A540 and she's getting this error even with the 16MB card that came with the camera. What's the point of a camera if you can loose the pics any time. At times you're capturing once in a lifetime moments, you want to be able to depend on the camera.
Shatsi is offline   Reply With Quote
Old Dec 5, 2006, 10:11 AM   #133
Junior Member
 
Join Date: Nov 2006
Posts: 20
Default

OK, now mine has the same problem. Maybe its contagious:?

I'm going to return it while I can.
Shatsi is offline   Reply With Quote
Old Dec 15, 2006, 1:49 AM   #134
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

I thought Canon had fixed the memory card error problem on the S3. Boy, was I wrong! Since the begining of this thread, I've being saying that the problem is not with SD cards but with Canon cameras. Back in May I bought a Panasonic FZ20 and I use 1 and 2 Gb EP high speed cards w/o any problems. The same cards were rejected by my Canon S2. I'm glad I got rid of the camera, not the cards. They are fine!!!
Tullio is offline   Reply With Quote
Old Dec 15, 2006, 4:22 AM   #135
Junior Member
 
Join Date: Nov 2006
Posts: 3
Default

That's right - the problem is not with the cards. Canon really need to do something about this!
JJLee is offline   Reply With Quote
Old Feb 6, 2007, 10:53 AM   #136
Junior Member
 
Join Date: Feb 2007
Posts: 1
Default

Hello forum!

Sorry for digging up this old topic, but I got the same Memory Card Error "Card Locked!" problem on my IXUS 65. I read through this topic and see that you`ve come to descision that this is not a card problem, but Canon makes bad cameras. I really didnt want to believe that so I did some more digging on the net and now have one more possible solution/explanation to this problem. As far as I know, Canon cameras don`t like shitty noname memory cards and work properly only with authentic brand made cards.
It has come to my attention that many fake memory cards are widely available on the market and not only on the internet. The counterfit cards look almost identical to the original ones but are really some noname low-quality cards with the look of expensive ones. It is estimated that about 95% of memory cards sold on ebay are not the real deal, tho they look like it. I also discovered that my 2GB SanDisk Ultra II is a counterfit and I`m going to refund it and try to get an authentic card to see if that fixes the problem. I`ll get back to you guys on that one.

In the mean time, it would`nt hurt to check if your card, which is causing you the trouble, is authentic or not. Try google to find how to identify other brands but if you have SanDisk Ultra II then you can check out http://reviews.ebay.com.au/FAKE-SanD...00000001254852



All the best,
Marko
insidefake is offline   Reply With Quote
Old Feb 6, 2007, 7:10 PM   #137
Junior Member
 
Join Date: Nov 2006
Posts: 3
Default

Marko,

It's true that there are some low quality cards out there that may well be DOA (dead on arrival) and therefore won't work, however, the problems described above occur even with the best quality Kingston and SanDisk cards. I know most of those who experience them have tested several cards of varying standards.

Good luck with your tests. Please do report back your findings!

Best wishes,
JJLee


JJLee is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:21 AM.