Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jul 18, 2005, 11:54 AM   #21
Junior Member
 
Join Date: Jul 2005
Posts: 1
Default

I bought a IXUS 700 last week, took about 50 photos and got the memory card error. Battery was low at time, but now, even with fuly charged battery it is no different. Can photos be retrieved with memory card reader? What are you supposed to do in future?
Jean London is offline   Reply With Quote
Old Jul 19, 2005, 1:32 AM   #22
Junior Member
 
Join Date: Jul 2005
Posts: 2
Default

You can retrieve datas from cards - I took my old camera and retrive pictures from that one.
I talk with supplier of my camera and they said that Kingston cards and canon S2 are not compatible. But as I read ths forum, you had also problems with other cards!?

Which one is now good for Canon S2???
GoUp is offline   Reply With Quote
Old Jul 19, 2005, 12:02 PM   #23
Junior Member
 
Join Date: Jul 2005
Posts: 1
Default

I have exactly same problem and same temprory solution (uploading via card reader and deleting all images).

I am using Byte Store and ithas 1 GB capacity and this is my second card, i have tought the first one has a problem but after getting second one, I have encountered the same problem.

Probably it is arising from Canon IS S2 itself, agreed.

I didn't want to give camera back since I like it very much. Actually I am waiting a firmware update.


Otake is offline   Reply With Quote
Old Jul 20, 2005, 6:29 AM   #24
Senior Member
 
Carrots's Avatar
 
Join Date: Jun 2005
Posts: 377
Default

I am about to order a Sandisk 512MB card (normal speed) for my S2. Anyone know if this will work from experience?

Either that or a 1GB Ultra II, also Sandisk.
Carrots is offline   Reply With Quote
Old Jul 22, 2005, 11:50 PM   #25
Junior Member
 
Join Date: Jul 2005
Posts: 1
Default

I too have a canon S2 and the same memory problem. with a 1GB Kingston Elite Pro, the card sometimes gives a "memory card error" . The pictures can no longer be viewed on the camera. However, it is possible to put the sdcard into a USB memory card reader and download the photos into the computer.

Once that is done I can reformat the card on the computer (using FAT not FAT32), then put it back in the camera and do a low-level format there. Everything works fine till the next 'memory card error". It is annoying.

What is interesting is that I also have a 256M Kingston Elite Pro, as well as a regular speed 256M Kingston SD card. neither have given any problem.

So I suspect the problem is with the 1GB card specifically. If you look at the other posts on the web, a lot of complaints are with the 1GB card, but i hardly find any for lower capacity ones.

ps: it may have something to do with the battery/power requirements. On a couple of these occasions, the problem occured when my battery was running a bit low.
kwanghui is offline   Reply With Quote
Old Aug 3, 2005, 11:05 PM   #26
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

Another data point, I just bought an A510 a couple of hours ago, started playing with the included Canon MMC-16M card with fresh (included) AA batteries, and was able to take pictures very easily. However, switch to playback and I get the dreaded corrupted data or memory card error messages. Nothing suggested here worked. I'm STILL able to take MORE pictures, and every once in a while I'm able to format it and take new pictures. Totally useless. Fortunately the store had a deal (they probably had irate customers complaining and started doing this) where I got a free SanDisk SD 128MB. That card WORKS FINE. Same batteries, environment, pins, pictures, etc. Back and forth, the problem exists only with the Canon MMC-16M card included with the camera. Even movies I can record, but not play back (something about bad image format or something). However, with the SanDisk SD 128MB I can record and playback movies just fine.
urukhai is offline   Reply With Quote
Old Aug 5, 2005, 4:37 PM   #27
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

Same problem with the Canon S2 and memory card errors. RETURN YOUR CAMERAS NOW. The number of posts here regarding memory card errors with Canon's new S2, with differing brands of cards, clearly indicates that the S2 has been released with a major defect and needs to be recalled. I'm returning my defective S2 ASAP to the retailer and will wait and see how the new Kodak P850 holds up in the reviews. The specs of this new Kodak camera blows the competition away. Canon screwed up big time on this one.
fredfass is offline   Reply With Quote
Old Aug 5, 2005, 4:45 PM   #28
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

Same memory card error problem with my new Canon S2. The sigificant number of posts here regarding memory card errors with Canon's new S2, with differing brands of cards, clearly indicates that the S2 has been released with a major defect and needs to be recalled. I'm not waiting to be left holding this crap -- I'm returning my defective S2 ASAP to the retailer. I'm hopeful that the newly announced Kodak P850 holds up in the reviews -- the specs of theh P850 blows the competition away. Canon screwed up big time on this one, IMO.
fredfass is offline   Reply With Quote
Old Aug 6, 2005, 7:56 PM   #29
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

Update to my data point: went back next day, returned whole package, got new A510 package, this Canon MMC 16MB memory card works JUST FINE. End of story for me. Very happy with the camera itself.

urukhai is offline   Reply With Quote
Old Aug 6, 2005, 11:08 PM   #30
Member
 
Join Date: Jul 2005
Posts: 53
Default

So far, the two SanDisk 1 gig EXIII cards I bought for the S2 have not given any trouble. I have not filled either one to capaciy with stills before transferring them to a PC, but I have filled both to capacity with video many times. I hope they keep working.... It would be nice if Canon were a little more willing to comment on the issue.

Voyager
Voyager13b is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:43 PM.