Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jul 21, 2005, 3:45 PM   #1
Junior Member
 
Join Date: Jul 2005
Posts: 3
Default

Hello! I've got this trip to Canada coming up at the end of the month and now my Canon S30 has konked out and no it's not because of the battery or the flash card. Has anyone else had their camera fail suddenly? To troubleshoot even further I tried to connect the camera to my MAC G4 and it tells me it's NOT attached. sigh.

To make matters worse i looked into repair and I'll have to send it to Canon in California...I hardly think there's time to get it back by the end of the month.

Suggestions?? Thanks so much!

p.s. I've had this camera for years and it's been a real performer for me. Here's one of my photos:

exoticat is offline   Reply With Quote
Sponsored Links
Old Aug 4, 2005, 2:30 AM   #2
Junior Member
 
Join Date: Jul 2005
Posts: 3
Default

I hope you bought a new camera to solve the problem.
exoticat is offline   Reply With Quote
Old Aug 4, 2005, 2:36 AM   #3
Junior Member
 
Join Date: Jul 2005
Posts: 3
Default

Yes, I did. A Canon SD400, in fact.

Here's a shot of my kitty wearing my brand new red tiki:

exoticat is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:51 AM.