Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Aug 25, 2005, 12:47 AM   #1
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

My camera is a new Canon Powershot A95 and I'm already having some trouble. I have a memory card in my camera which is insterted properly, brand new and it keeps telling me that there is "No memory card." I've tried taking it out and cleaning it slightly, but no luck at all. When I put it back in it still says that there is "No memory Card". Oh yes, and the memory card is not full so there shouldn't be anything wrong. Can anyone help me?
Chalice Inouva is offline   Reply With Quote
Sponsored Links
Old Aug 28, 2005, 11:52 PM   #2
Junior Member
 
Join Date: Aug 2005
Posts: 2
Default

Anyone?:O
Chalice Inouva is offline   Reply With Quote
Old Aug 29, 2005, 2:17 AM   #3
Junior Member
 
Join Date: Jul 2005
Posts: 21
Default

You did not mention if the card is the orginal card which came with the camera and of what size - as some of the Canons are a bit allergic to 1 GB and 512 MB cards....

However, you should try the camera with another card - andcheck ifyou still have this error. Ifyou get it also with another card - the problem is with the camera and since it is new youshould contact the shop.


Rachel2nd is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:34 AM.