Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jan 15, 2006, 1:33 PM   #1
Junior Member
 
Join Date: Jan 2006
Posts: 2
Default

My S1 is around 6 months old and today when taking a photo the flash (I'm assuming) made a very loud "pop" sound, similar to what you hear when a light bulb blows out when you turn it on. Has anyone else had this happen or know what causes it? Do I need to have the flash replaced? Is it even replaceable/repairable?

Thanks!
Laurie
lauriecas is offline   Reply With Quote
Sponsored Links
Old Jan 16, 2006, 1:38 AM   #2
Member
 
Join Date: Oct 2005
Posts: 47
Default

I would have to assume that with the way the flash works, that it would be normal to hear a certian pop to it. Much of which depends on the intensity of the flash required, the more powerful the flash, the louder the "pop" will be heard. Now, if it is just unusually loud, you may want to have it checked out just in case.
Buhammot is offline   Reply With Quote
Old Jan 16, 2006, 10:57 AM   #3
Junior Member
 
Join Date: Jan 2006
Posts: 2
Default

It was very loud....heard from the other end of the house loud. It scared the dickens out of me. :-)

I've spoken to someone at Canon, they say they have never heard of such a thing happening and to send it in for warranty (hopefully) service. Looks like I'm going to be without a camera for weeks at least. :sad:
lauriecas is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:36 AM.