Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Mar 21, 2006, 9:35 AM   #1
Junior Member
 
Join Date: Mar 2006
Posts: 2
Default

I recently purchased the S2 and plan on using the Sandisk Ultra II 2.0 GB memory card. Has anyone had any problems with the card? The reason I'm inquring is that I have seen some negative reviews for this card and am just wondering if they area result of operator errors or a real issue with the card. Any feedback would be greatly appreciated. Thanks.
formrbankr is offline   Reply With Quote
Sponsored Links
Old Mar 22, 2006, 11:23 PM   #2
Junior Member
 
Join Date: Mar 2006
Posts: 1
Default

I bought a Sandisk Ultra II 2g about a month ago and have had no problems with it in my S2. I've taken prolly 800 or so pics with it with no problem. I recorded the 1 gig max movie size a few times to test that part also when I first received it. No problems so far.




ritepath is offline   Reply With Quote
Old Mar 26, 2006, 10:27 AM   #3
Junior Member
 
Join Date: Mar 2006
Posts: 2
Default

ritepath, thanks for your reply.
formrbankr is offline   Reply With Quote
Old Mar 27, 2006, 11:04 PM   #4
Junior Member
 
Join Date: Mar 2006
Posts: 7
Default

My week old S2 DESTROYED two Sandisk Ultra II 1GB cards over a 3 day period. The camera is being returned and a replacement is on the way. Not sure why or how it happened, but it wasn't pretty !
guitarfish is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:54 AM.