Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jul 16, 2006, 5:31 PM   #1
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

I've been playing with my S3 for a week now, and its a great camera for beginners wanting to move up the camera ladder.

One thing I've noticed is that the handgrip makes a slight clicking sound everytime I grip it more firmly than usual.

Has anyone else noticed this or is this a problem with the unit I got?
jansci is offline   Reply With Quote
Sponsored Links
Old Jul 16, 2006, 6:14 PM   #2
Junior Member
 
Join Date: Jun 2006
Posts: 15
Default

Mine doesn't do that.
dr88keyz is offline   Reply With Quote
Old Jul 17, 2006, 6:42 AM   #3
Junior Member
 
Join Date: Jun 2006
Posts: 1
Default

Mine doesn't do that either.
ACVahl is offline   Reply With Quote
Old Jul 18, 2006, 3:23 AM   #4
Junior Member
 
Join Date: Dec 2005
Posts: 19
Default

Havent had that problem, I love the camera, what do you plan on upgrading to???
drailog is offline   Reply With Quote
Old Jul 18, 2006, 12:28 PM   #5
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

Looks like I'll be taking the unit back to the dealer...the entire plastic body of the S3 feels rickety.

When I'm confortable with all the camera terminology and techniques, I'd like to move to the EOS or Nikon's D-series cameras.
jansci is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:13 AM.