Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Reply
 
Thread Tools Search this Thread
Old Jul 16, 2006, 8:12 PM   #1
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

Hi all,

New member and I hate to have to introduce myself by way of a problem that I hope I can get some help with. In the process of turning it on today the wife had held the camera's lenscap against her hand and did not realize it - it then stopped powering up with the lens in a semi-open position (ie. not fully extended). It also powered down.

Now, it refuses to power back up and I've not found any help in the manual or the Canon web help section...

Hoping that there may be some other solution that some of you could suggest or know of!

Much appreciation in advance,
C.K.
CKLee is offline   Reply With Quote
Sponsored Links
Old Jul 17, 2006, 12:19 AM   #2
Senior Member
 
propwash's Avatar
 
Join Date: Aug 2004
Posts: 277
Default

I'm not that familiar with the G6, but some people in a similar situation have had some success by removing the batteries completely from the camera for up to 24 hours, recharging them and then reinserting the batteries. You can give this a try if you don't get any better suggestions from anyone else. Good luck.
propwash is offline   Reply With Quote
Old Jul 17, 2006, 9:55 AM   #3
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

Well at this point its as good a suggestion as any... I'll give that a try. I'm sensing a very near-future visit to the repair centre though... thanks Hope it works!

CK
CKLee is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:59 AM.