Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old Jun 9, 2005, 3:59 PM   #1
Junior Member
 
Join Date: Jun 2005
Posts: 2
Default

I have just recieved my ex-z750 today. Charged it up as the manual asks.

As i take each photo the lcd turns blank expect for the viewfinder,like it the "Display" button has been pressed. I know it has something to do with the display becuase i can continue taking photos but with a blank lcd. The only way to get anything back on the lcd is to press the "display" button a few times, almost like i have to cycle through the display options to get back to the normal mode.



Can anyone help me with this problem or is this a "send it back" job?
Joshbonze is offline   Reply With Quote
Sponsored Links
Old Jun 9, 2005, 6:18 PM   #2
Junior Member
 
Join Date: Jun 2005
Posts: 3
Default

Try resetting the camera to its original settings. The blank LCD is an option when you cycle through display in order to conserve your batteries.
boarder51x is offline   Reply With Quote
Old Jun 10, 2005, 5:00 AM   #3
Junior Member
 
Join Date: Jun 2005
Posts: 2
Default

Ok, have just spoken to casio and the problem is fixed. Apprently after 2mins of being fully charged it got a corrupt file that messed up the display. This was fixed with a simple re-format.

Everything seems fine now and now my anger had died down i can appreciate what a great little camera this is.

So if this problem happens to you just re-format the memory (internal and card).
Joshbonze is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:02 PM.