Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old Jan 27, 2006, 7:16 AM   #91
Junior Member
 
Join Date: Jan 2006
Posts: 2
Default

I like the Exilim Ex Z750 andf its great features but, boy, the lensissensitive. Just a slight drop from the tripod was enough to damage the lens which then refused to shut. The camera and allits controls went dead. The CASIO agent here in Australia quoted to fix the camera :for roughly the same price as it would cost to buy a new one. It means that this small mishap has rendered a A$500camera absolutely worthless. It seems I now have a worthless piece of junk. My previous camera was primitive in comparison, but lasted five years, not just a few weeks.
Click2006 is offline   Reply With Quote
Old Feb 7, 2006, 9:08 PM   #92
Junior Member
 
Join Date: Feb 2006
Posts: 1
Default

Hi,

9029xxxA, China, Anthricite model, 1 gig ultra 2 sandisk.

Shot a few hundred pictures and a few min. of video.

Great reading, sorry to see that the Casio techs have dropped out they were very informitive.

Got my 750 on 1-3-06 only 1 problem so far. When I first got it the lens came out one ortwo times, froze upand the screen was black.

First time I pulled the battery and it corrected it. Second time I read the book and formatted the card. Fixed it. No problems since.

First thing I purchased was a nice case, then clear screen covers.Both are a must have for this unit.

I will be following the advice here, gentle handling and changed the auto settings as well as storing it in the audio record mode.

Only feature I dont like so far is the extra zoom, it blures out completly.

Any setting to change to keep it clear?

Thanx to all who have posted and I hope I can offer help later after I have used it for some time.


ampm is offline   Reply With Quote
Old Feb 8, 2006, 2:06 AM   #93
Junior Member
 
zorniki's Avatar
 
Join Date: Jun 2005
Posts: 6
Default

Well ampm, I guess that´s pretty much the case with every digital zoom out there...the picture will pixelate and blur!

Seems you´re doing all the precautions one could do with that camera

Have fun!
zorniki
zorniki is offline   Reply With Quote
Old Feb 8, 2006, 1:51 PM   #94
Member
 
Join Date: Aug 2003
Posts: 49
Default

Geez.....i was going to hold off till the Z850 is announced and see what the differences are. Now after reading this thread i'm afraid to buy either !
dazco is offline   Reply With Quote
Old Feb 28, 2006, 9:24 PM   #95
Junior Member
 
Join Date: Feb 2006
Posts: 1
Default

Hi!* I bought my Z750 in Canada in November 2005 and brought it back with me to Germany where I live. On my trip 2 weeks ago I started getting* "lens error "on my screen but if I turned the camera on and off it would go back to normal. Now I went to show a friend the photos I took of my trip, the lens popped out to its full length and then... NOTHING! I can't turn it off or on, the computer doesn't recognize it when its set up with USB. There is a very faint whirling sound when I go to turn it on, looks like the lens might be trying to do something but to no avail. So now it's just stuck there with the lens fully extracted. I think my warranty is only good for Canada, so I might need to send it all the way back there to get it fixed. Does anyone have any suggestions? Or any addresses in Germany? I live in Berlin.*This sucks...Thanks a lot for your help!
shortylaurie is offline   Reply With Quote
Old Mar 1, 2006, 3:21 AM   #96
Senior Member
 
Join Date: Oct 2003
Location: Indian Rocks Beach, FL
Posts: 4,036
Default

dazco wrote:
Quote:
Geez.....i was going to hold off till the Z850 is announced and see what the differences are. Now after reading this thread i'm afraid to buy either !
They have fixed the problem with beefier gears. I don't think very many cameras that came originally with firmware version 101 had the old gearing and none of the cameras with firmware v102 do.

There is still old stock around. The anthracite/gray Z750 version should all have the new gearing and all of the Z850s will.

slipe is offline   Reply With Quote
Old Mar 23, 2006, 4:02 PM   #97
Junior Member
 
Join Date: Mar 2006
Posts: 1
Default

My camera died after eight months in service, and I was annoyed because its was the best camera in terms of features. First the 'lens error' problem appeared and the lens refused to come out the first time, then a few weeks later the LCD screen developed a crack. Taking pictures through the viewfinder is no good as you can not adjust any controls or modes. The Casio service department refused to repair it under warranty, saying it was my fault (nice !). The repair cost was nearly as much as the camera itself, so I opted for a second option: to repair the LCD myself. It cost half the price for just the part, and four solder joints later I had my camera back. I am happy it is working again and the 'lens error' problem has gone away.If you are not squeamish, the details of this DIY job can be found at http://www.ok2life.com/welcome/index/35.html
Attached Images
 
ezusbo is offline   Reply With Quote
Old Mar 24, 2006, 8:44 PM   #98
Junior Member
 
Join Date: Mar 2006
Posts: 4
Default

Be afraid, be very afraid... I just received my new 850, just in time for my trip out of town!...
Fresh out of the box with the wonderful "LENS ERROR". Casio has some serious issues when they continue to introduce their design flaws into the next gen products.
rickpub is offline   Reply With Quote
Old Apr 16, 2006, 11:56 PM   #99
Junior Member
 
Join Date: Mar 2006
Posts: 1
Default

Does anyone know if one can recover files on a SD card which has been formatted in error?
EX-Z850.

Len Schloff
[email protected]
lenschloff is offline   Reply With Quote
Old May 18, 2006, 1:49 PM   #100
Junior Member
 
Join Date: Mar 2006
Posts: 29
Default

I HAVE BEEN CALLING CASIO TO ASK IF THEY HAVE ADDRESSED THE LEN ERROR PROBLEM IN THE Z850, AND REALLY CAN'T GET A ANSWER, OTHER THAN THEY HAVEN'T SEEN AN COMPLAINTS. WHERE DID YOU GET THE INFO THAT THEY CHANGED GEARS?

ALSO, I AM NOT SURE WHAT FIRMWIRE IS AND HOW IT WORKS...

ANY HELP WOULD BE GREAT.... THANKS ED
FAST EDDIE is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:38 AM.