Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old Sep 15, 2005, 3:22 PM   #61
Junior Member
 
Join Date: Sep 2005
Posts: 9
Default

I am unsure what exactly causes the focusing problem as yet. However you should be able to get the lens unit replaced under warranty to fix the problem.

As someone posted earlier, the focus problem seems to begin after the lens has tried to open while the camera is inside its case.
CASIO Service is offline   Reply With Quote
Old Sep 16, 2005, 8:30 AM   #62
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default

Hi people, I had "Lens Error" too and the fix was very simple...Some rust happend inside the camera (due to some water drop or something, I was taking pics just above sea water) and once that rusty part has been cleand and lubed everything worked as new. So, if you wanna save some $ 50 or so do it yourself, carefully open camera, inspect it and if you see some rust or any other dirt clean it and you are all set.

You don't need any firmware upgrade for this.
Joe_Joe is offline   Reply With Quote
Old Sep 16, 2005, 8:33 AM   #63
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default



Joe_Joe is offline   Reply With Quote
Old Sep 17, 2005, 8:47 PM   #64
Junior Member
 
Join Date: Sep 2005
Posts: 1
Default

CASIO Service wrote:
Quote:
The camera comes with a list of all the service agents around the world in the box. Check that list and phone your nearest agent for service.

CASIO has a full international warranty as long as you have your proof of purchase.
I am seriously considering the purchase of this camera. But, i was wondering where i could get it serviced if there are problems, in Canada?
kanadian is offline   Reply With Quote
Old Sep 18, 2005, 3:21 PM   #65
Junior Member
 
Join Date: Sep 2005
Posts: 9
Default

Please follow this link for a list of Authorised Service Agents

http://www.casio.com/index.cfm?fusea...upport.service
CASIO Service is offline   Reply With Quote
Old Oct 27, 2005, 12:58 AM   #66
Junior Member
 
Join Date: Oct 2005
Posts: 10
Default

is there an Official fix for this yet. Meaning when you send your camera in for repair they will actually fix it so it wont happen again. Or turnt he sencitivity down anyway? any news?
epion2985 is offline   Reply With Quote
Old Oct 27, 2005, 2:55 PM   #67
Junior Member
 
Join Date: Sep 2005
Posts: 9
Default

Sorry I have not heard of anything yet. But please read the attached document. Following the precautions mentioned in this document will eliminate the chance of damaging the lens.
Attached Files
File Type: txt EXZ750 Lens error.txt (911 Bytes, 533 views)
CASIO Service is offline   Reply With Quote
Old Oct 30, 2005, 8:58 PM   #68
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

I had an EX-Z55 but I sold it to my brother in-law and "upgraded" to an EX-Z750 (serial #7132xxx - china) in Aug05.* I loved my Z55 but I do not feel the same about this new unit.* I began experiencing lens errors and auto focus failures about a month after my first photo.* I upgraded to version 1.01 today but I continue to experience the same issues.* I have a 1GB SD card. Something I have not seen noted on this string is that this unit is much louder than others, including my Z55...lots of clicking and clacking going on when ever the power is turned on and the lens is activated. * *Honestly, the photo quality was better with my Z55.
AvgGuy is offline   Reply With Quote
Old Oct 30, 2005, 10:35 PM   #69
Member
 
Join Date: Oct 2005
Posts: 37
Default

Hi AvgGuy, just to check, did you disable the REC/PLAY power on option before the lens error occur? Or even when you disable it, the lens error still appear? Thanks.
Brainstorm is offline   Reply With Quote
Old Oct 31, 2005, 6:22 PM   #70
Junior Member
 
Join Date: Oct 2005
Posts: 4
Default

Good question.* I just disabled it yesterday after reading what the others had written.* Post adjustment I am still experiencing lens errors and auto focus problems.* I called Broadway Camera (where I bought it) and they said to return it to them for repairs however, I also called Casio and they said to return it to them for repair.* Any advise?
AvgGuy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:07 AM.