Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old Dec 27, 2005, 4:50 PM   #1
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

I need your advice, Casio owners. Long story short, I bought an EX-Z750 in August. Fantastic camera, when it works. In late November it developed the lens error problem that's apparently plagued so many fellow 750 owners. Lately the lens error message appears whenever I zoom inor out. Also, the auto-focus isn't all that sharp (apparently, another common problem). So here are my choices: (1) Return the camera to Costco for another EX-Z750 (which might develop the same problem). (2)Return the camera and get an EX-Z55 (which doesn't seem to have the problem). (3) Send my camera to Casio in New Jersey for a warranty fix (which could take weeks -- and result in a refurbished replacement, which I don't want). For the record, my EX-Z750 was made in China, and its serial # is 1109XXXX. Also, I've seen some 750s that have "Exilim" on the front in color. Mine's in brushed silver like the rest of the camera. Is mine a so-called 'gun metal' model? Thanks so much for your help, and have a very happy new year!
Stewie_Griffin is offline   Reply With Quote
Sponsored Links
Old Dec 27, 2005, 11:19 PM   #2
Member
 
Join Date: Oct 2005
Posts: 37
Default

Like to ask if you have set the "REC/PLAY" to "Power On", Power On/Off" or "Disable" from thefirst dayyou bought the camera? Please note that this will not sovle your existinglen error, just want tosee if those who have disabled the "REC/PLAY" from thebeganing will not get lens error subsequently. Thanks.
Brainstorm is offline   Reply With Quote
Old Dec 28, 2005, 2:51 PM   #3
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

It was set to "Power On" (default).
Stewie_Griffin is offline   Reply With Quote
Old Dec 29, 2005, 2:36 AM   #4
Member
 
Join Date: Oct 2005
Posts: 37
Default

Ok, then maybe this will help you with your options. I also bought Z750 in Oct 05 and set the "REC/PLAY" option to "Disable" on the very day. Till now, I did not suffer from any lens error or out of focus problem.Furthermore I keep it in a small tight Lowepro bag (model: D-pod 10). Mine also made in China.

So its option 1 or you may want to consider option 2 but change to the new S600!?Forget about option 3.... Just my 2 cents...

Cheers.
Brainstorm is offline   Reply With Quote
Old Dec 30, 2005, 2:21 AM   #5
Junior Member
 
Join Date: Sep 2005
Posts: 19
Default

As for your question regarding the colour of the Exlilim writing on the front, if yo aim the camera at strong unnatural light and move it around you should see the rainbow effect on the logo, its just because of the silver materail they have used...
Deanis is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:14 PM.