Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old Feb 10, 2006, 12:02 AM   #1
Junior Member
 
Join Date: Feb 2006
Posts: 1
Default

I bought the camera about 3 days ago worked fine charged it. Took a few pics. While changing the settings the camera turned off. I tried to turn the camera back on to retract the lens but the lens the camera did not respond. All I get is a green blinking light and a weird mechanical sound. The camera was not dropped or abused it is literally brand new. I am going to call casio but I am curious to know if anybody else experienced this problem. The camera does not turn on at all. What the F*** could be the reason im really confused and angry. Plzz suggesttionsss
Cameramanyak is offline   Reply With Quote
Sponsored Links
Old Feb 10, 2006, 3:29 PM   #2
Member
 
Join Date: Aug 2003
Posts: 49
Default

I wouldn't bother calling casio. They may ask you to send it in for repair, and thats not necassarily a good thing. Just take it back to the retailer. At only 3 days old they'll surely excahange it for a new one. Sending it in for repair may result in a long wait and the return of a camera that wasn't right to begin with. And often in those cases you get back the item only to find it's still having problems. return it to the store for a new one that works righ to begin with.
dazco is offline   Reply With Quote
Old Feb 11, 2006, 3:04 AM   #3
Junior Member
 
Join Date: Feb 2006
Posts: 1
Default

Have you tried removing the battery and waiting a few second before putting it back in?
raylowe2001 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:05 AM.