Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Reply
 
Thread Tools Search this Thread
Old May 21, 2006, 11:38 AM   #1
Junior Member
 
Join Date: May 2006
Posts: 2
Default

I have an EX-Z600 that when plugged into my PC or laptop, I recieve an error "USB is not recognized". The USB setting in the camera is set to mass storage and when the mem card is used in a reader its fine.

The PC is running XP Home and the laptop is using XP Media. Both machines are current with updates.

I had a Casio before this one and it worked fine. Any ideas?
Nokomis is offline   Reply With Quote
Sponsored Links
Old May 31, 2006, 9:32 PM   #2
Junior Member
 
Join Date: May 2006
Posts: 2
Default

My brother just bought an EX-Z600 from Circuit City and has the exact same problem. We tried it on 3 computers running XP and they all produced that error. The memory card also works fine with a reader.

I talked to a guy I know about it and he said it may be a bad connection between the camera and the connection on the dock. He often experiences similar problems with his Palm Trio.

My brother took his camera back to CC today and should be getting a replacement tomorrow. I'll post an update when we get it.
cagilber is offline   Reply With Quote
Old Jun 3, 2006, 6:37 PM   #3
Junior Member
 
Join Date: May 2006
Posts: 4
Default

I have the same or similar problem for my EX-110. It won't show up at all. yet the card works fine in a card reader however when I took it into the shop where I Purchased it from it connected to there computer ok :S
bwbw is offline   Reply With Quote
Old Jun 4, 2006, 2:56 PM   #4
Junior Member
 
Join Date: May 2006
Posts: 2
Default

We returned the "defective" EX-Z600 and got a new one. The problem hasn't occured yet with this new camera so I'm guessing it was a faulty dock connection.
cagilber is offline   Reply With Quote
Old Jun 12, 2006, 10:49 AM   #5
Junior Member
 
Join Date: May 2006
Posts: 2
Default

Well, I tried to get the people at Circuit City to try my camera in a different dock or even just to plug my dock into one of their computers to see if it would recognize the camera. The fact that the purchase was past the return date they said there was nothing that they could do and to contact Casio direct.

So much for customer service.

I guess Ill go buy a card reader and you can be sure Ill never spend another penny with Circuit City.
Nokomis is offline   Reply With Quote
Old Jun 15, 2006, 4:20 AM   #6
Member
 
omGARY's Avatar
 
Join Date: Jun 2006
Posts: 86
Default

wow.. thanks for the warning
omGARY is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:14 PM.