Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Dye Sublimation (https://forums.steves-digicams.com/dye-sublimation-44/)
-   -   Hi Touch 630PL (https://forums.steves-digicams.com/dye-sublimation/1534-hi-touch-630pl.html)

nnolan Jul 31, 2002 1:35 PM

Hi Touch 630PL
 
Just got this last week. Love: the size of the printer, the "photo" look of the prints, the fact that I can put my grubby piddies all over the pictures with few (if any) smudges, and the low cost of the print kits. Don't love: the blue/green cast to all the prints and the fact that I have to mail-order the print kits when I run out. I'm going to have to order Mike Chaney's profiling software and see if it helps my prints get over their "blues", I guess.

Greybird Aug 6, 2002 9:33 PM

HiTi630ps
 
Have had My 630PS for about 3 weeks now,ordered it the day Steve reviewed it, and am really enjoying it . Have no problems with the " blue /green cast", in fact I make 4x6 prints from it using several programs, and then make full sheet edge to edge on my Canon S820, and there is no difference in the Quality or color. As far as ordering the print kits, I ordered two spare and had tem in a week. I plan to take it too our village functions and make instant prints..Hope you solve your problem.. OBTW have you downloaded the <a href="http://www.hi-ti.com/maindownload.asp">firmware and software update</a>??
Herb S

[Edited on 8-15-2002 by steve]

nnolan Aug 8, 2002 9:37 PM

Software update?
 
I didn't even know there was one; maybe that will fix my "blues". I've got more print kits on order, so I can test this when they come in. Thanks for the info!

Greybird Aug 9, 2002 8:51 AM

HiTi630PS
 
Hi again nnolan;
I just thought about another thing , go to the page you get when you print a picture and go to the last page. this gives you instructions on how to print a test page , and how to calibrate the printer. This is really a great little printer for 4x6 prints, and the cost per print is sonething else..
Herb S:P

jaguar Aug 30, 2002 3:51 PM

Re: nnolan
 
I too am experiencing the greenish cast in photos printed on my Hi-Ti 630PS. I did the firmware update but this didn't seem to make a difference. Have you been able to resolve the issue?

jimford Aug 31, 2002 7:00 PM

Re: HiTi Blue colur cast
 
I'm also getting the blue colour cast reported by others. I'm awaiting a reply from HiTi on this. (I've also reported this problem in the printers forum of dpreview.com)

Regards: Jim Ford

ljohn1950 Oct 10, 2002 1:54 AM

Hi Touch 630PL
 
After reading all of the reviews and post about the Hi Touch i picked one up Friday in Seattle at Glazers camera (they have a fantastic digital/video store and staff) I think thy named this printer wrong. it should have been named the WOW-630PL because every time i show someone the photos printed by it they say WOW. there was one HOLY SMOKE also. the color is perfect no color shift.
Larry

mlciskey Oct 13, 2002 6:25 PM

Does it come with a .ICM color profile for use when printing connected to a computer?

Thanks,
Mark

Binji7 Oct 30, 2002 3:54 PM

It sure does have a color profile included with it. I'm in the process of tryng to sync the color on my Dimage 7i , Monitor and PL-630PS. The Silver color of the Printer really goes nice with the Dimage 7i, now I just need a silver case and monitor. Time to get some spraypaint!!!! All in all I am VERY, VERY happy with the printer. A little slower in stand alone mode than I'd like. But I've already made $200.00 bucks selling picks at a local 'hole in the wall' pub and I'm still on my first pack of paper.......

lobomayo Nov 6, 2002 8:23 AM

Re: nnolan
 
Quote:

Originally Posted by jaguar
I too am experiencing the greenish cast in photos printed on my Hi-Ti 630PS. I did the firmware update but this didn't seem to make a difference. Have you been able to resolve the issue?

when you speak of "firmware updates", are you referring to driver updates?
My PL makes great prints when it works, but it often needs to be restated to work properly (I get various error messages). Anyone else had this problem? I'm running Win 98SE.

Binji7 Nov 7, 2002 10:18 PM

I have the 630-PS and never had a problem. I've printed 10 shots back to back without a hitch.

ehanley736 Dec 12, 2002 1:58 PM

Just purchased the 630PS for My Father for X-Mas. Had to try it out though with all the talk of green/blue tint. Wow was the first thing out of my mouth when the photo came out!!! Outstanding print quality. Had 3 of the same photos printed at 3 different labs and the photo printed on the 630ps was just as good as the best of the 3, if not better. No greenish tint. Just a great Photo. WOW!!!

gibsonpd3620 Dec 12, 2002 3:29 PM

My HiTi 630ps is under the Christmas tree. I did print two prints to make sure everything was working. The picture output was perfect. My partner was impressed he is ordering one for himself. Mrs Claus will not let test the pritner anymore until after Christmas. I experienced no green or blue tinting just super prints.

Gregersonsalvage Dec 12, 2002 5:17 PM

Green/blue hue is in the eye of the beholder IN my experience HP tends to do this a little more in substitute for dark blacks in order to get the shades out a little better. SO you may not notice it as much. Dye sub printers tend to pull out the shades and vividness very well. Although your problem could be a simple one such as digital camera correction over the standard icm. This is included in some printer drivers. YOU should go looking through your printer driver for the correction.

What I would do is get a print from a photo lab and get a print from your printer and you will see the difference. That or you can take a picture of something that is not white specifically but somewhat on the offwhite like biege or an offwhite wall. Print then look at your photo you might see the blue tint in there when compared to the wall or the real object.

gibsonpd3620 Dec 25, 2002 9:05 AM

It is Christmas morning and the HiTi 630ps is unwrapped. It produces unbeliveable photos. The only problem I see is that there is no redeye reduction when running the printer without the computer. You can do some editing but it is limited. HiTi had firmware updates dated 12-23-02. They were easy to install. This is truly a digicam geek must have. Merry Christmas to all

voxmagna Dec 29, 2002 12:52 PM

If I had doubts about colour casts I'd make a set of increasing 10% grey patches using my editor, check the rgb levels were identical with the eyedropper and hit print! Always save as a bmp though.

If there are hues on printed out greys, then either the printer isn't tracking properly, or there is ICC in the way somewhere. If the file is saved as a bmp, it is possible to check byte values for the absence of ICC leaving the editor.

I'm watching postings for this printer with interest!

gibsonpd3620 Dec 29, 2002 3:14 PM

voxmagna

I have printed 50 prints and am not seeing any color casting. I also updated the ROM before I started printing after Christmas. The 630ps can only use jpeg files in the stand alone mode. You can print other formats when connected to your computer.

voxmagna Dec 29, 2002 4:51 PM

gibsonpd3620

Nice to hear a satisfied customer! But there does seem to be a few members at the top of this thread who still need help to solve a problem.

gibsonpd3620 Jan 6, 2003 5:38 PM

The HiTi 630ps is selling at $209. Check this site:
http://www.********.net/productpage.asp?pn=88P023600A

They also sell the paper packs for $17. Bringing the cost to 35 cents a pic.

Some issues that others are having can be corrected by installing firmware updates. The latest update is dated 12-24-2002.

pasaalcur Feb 3, 2003 4:47 PM

Streaks in Shadow areas
 
I have a new 630PS and am having streaks appear in the darker shadow areas of the photos and across the entire photo. The area are pretty much a constant color and I get the streaks in all the photos. They are not in the same pattern and changing the ribbon does not fix the problem. So far I've printed about 25 photos and they all have this problem.

I tested it independent of my camera by printing an image of solid gray from my PC and I still get these streaks. The color values that I tested were Red 96, Blue 95 and Green 90.

I would make much of the problem except that it is showing in all my photos. Has anyone else seen this?

gibsonpd3620 Feb 3, 2003 5:21 PM

Have you downloaded the firmware and software updates from hitouchimaging?

pasaalcur Feb 4, 2003 8:36 AM

Streaks
 
I've upgraded the Firmware, software, and driver. I've tried their "Adjustor" software. I've tried printing from a card. I've tried printing from a PC. I've tried adjusting brightness. I've tried adjusting contrast. The images still have streaks. Now, I'm out a pack of paper...

I've sent scans of the images to Hi Touch but so far haven't gotten any real answers other than, upgrade the firmware, try our "Adjustor" software, "Does it happen when you print from a card?"... Hopefully I'll get some resolution soon. I've had the printer for only 3 weeks and almost all of the photos I've printed are test.

So, what I am guessing is that no one else has seen any streaking. Hmmm.

gibsonpd3620 Feb 4, 2003 10:39 AM

I had no problem with my printer from the beginning. I printed over a hundred pics through the printer. I am ready to order more paper and cleaning kit. I am sorry that I can not be any more help.

dujie Apr 23, 2003 3:43 PM

Currently the 630 PS goes for $172.07 and the paper goes for $16.30 on www.********.net


All times are GMT -5. The time now is 8:10 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0 RC 2