Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Reply
 
Thread Tools Search this Thread
Old Apr 26, 2007, 7:06 PM   #1
Junior Member
 
socom's Avatar
 
Join Date: Jan 2007
Posts: 18
Default

I purchased a 430EX for my G7 and no matter what mode I try I cannot get the AF assist on the flash to work. Will it not work with my camera or do I have a defective flash?
socom is offline   Reply With Quote
Sponsored Links
Old Apr 27, 2007, 11:46 PM   #2
Junior Member
 
socom's Avatar
 
Join Date: Jan 2007
Posts: 18
Default

Anyone else have this problem? Any input would be great.
socom is offline   Reply With Quote
Old May 11, 2007, 7:18 AM   #3
Junior Member
 
Join Date: Feb 2006
Posts: 5
Default

Maybe you could take it back to the service!
gubakl is offline   Reply With Quote
Old May 13, 2007, 11:50 PM   #4
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,483
Default

socom wrote:
Quote:
Anyone else have this problem? Any input would be great.


The thing is, there is no "problem" with your flash. You are starting to find the "features" that are not supported by Canon's digicams that... supposedly... are " fully compatible" with their own flash guns.

Don't beat your head against the wall any further. It doesn't work. It isn't gonna work. It's not designed to work.You don't get that feature with digicamsthat have dedicatedhot shoes....any digicams. Nikon's digicams that havehot shoesdon't utilize the AF assist light of the Nikon speedlights and thePanasonic FZ50 does not support the AF assist light on their or the Olympus flashes, forwhich the Panasonic flashes are based. Fortunately for me, the FZ50 has it's own built-ininfrared focus assist light that does work when the flash is mounted.

You might as well know another good one about Canon digicams and EX flash units....one of my favorite ways to shoot a DSLR is to choose Manual exposure mode, set my own aperture and shutter speed, turn the flash on and let it work in TTL mode. I shoot indoors usually at 1/125 sec at f5.6/f8 and with DSLR's (and my Panasonic FZ50)the flash units work beautifully in TTL mode....

Try the same thing with your G7.... If it does the same thing the G5/6 did, switching your camera into manual mode automatically also switches your mounted EXflash into manual mode, only giving you the option of several manual flash bursts at various power levels...pretty useless for spontaneous shooting, and since Canon made the decision years ago to leave avaluable feature like non-TTL auto off their EX units, you have no fallback optionif you use yourcamera in manual mode, and the G series has always been a model series used by more advanced users, some of whommight be interested in using their flash units more creatively.

I also have no doubt the new S5is with it's "dedicated" hot shoe will have the same shortcomings when used with Canon EX flash units.

Welcome to the world of "buy our DSLR's" Canon marketing...it's the only way you'll get access to all the features of your Canon flash..

May 14 update.....

One other difference I forgot about....I havetried putting the time I triedusing a 420EX flash on a G5 out of my memory... the short pre-flash Canon flashes use in the exposure calculation...they are virtually instantaneous when the EX flash is attached to a DSLR. Well, when used with the G5 the pre-flash and actual exposure flash had a distinct delay and my subjects constantly had closed their eyes by the time the actual exposure flash went off...what a PIA!

If I haven't said it yet, enjoy the experience!


Greg Chappell is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:04 PM.