Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Reply
 
Thread Tools Search this Thread
Old Mar 12, 2011, 5:30 PM   #1
Junior Member
 
Join Date: Apr 2004
Posts: 3
Default Flash Problem (I think)

Hi. I got a G12 recently and a Speedlite 270EX for enhanced flash. I've used the combo several times in the last 3 months. Indoors, using Auto mode (main dial, not the flash) today I noticed when I put the 270EX on, locked in place and turned on, that the display flash "lightning" arrow goes on, but in orange and stays orange. The display flash arrow stays off until I turn the flash on, so there's a connection there. When snapping a photo, the flash functions but the orange (vs white) arrow is mystifying. I don't think I ever saw anything but white before, and have no idea what orange indicates (partially charged??). I put in fresh batteries, no change.

With the 270EX removed, the display shows the flash arrow in white, with "A" (flash auto mode) noted next to it. When taking a photo, all seems normal.

I took a photo in a dark room both w/o the 270EX onboard (builtin flash fired) and with the EX270 onboard. The display info on playback did not flag anything for me, basically the same info for both).

I'm concerned something is wrong. COmments?
peahrens is offline   Reply With Quote
Sponsored Links
Old Mar 12, 2011, 6:55 PM   #2
Junior Member
 
Join Date: Apr 2004
Posts: 3
Default

Well, I found something in the downloaded G12 manual...p. 180. It says the external flash (when on) will make the lightning(flash) symbol "red". I guess that's what mine does and I never noticed before today. If you can confirm for me what you see on yours, please me know so I can relax.

Meanwhile, I'll be going through the manual again!
peahrens is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:38 AM.