Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Reply
 
Thread Tools Search this Thread
Old Oct 2, 2002, 8:33 AM   #1
Senior Member
 
Join Date: Jun 2002
Posts: 194
Default sb-80dx does not fire

Iím using this speedlight with my d1x dslr. The flash is inconsistent with the recycle time. Some times itís a few seconds and other times itís a lot longer. Other times the flash doesnít even fire at all. Iím not sure the prob. This just happened recently. The flash and camera is only a few months old. Iíve tried new AA batteries(1800). The battery in the camera is full also. What is wrong? Or maybe Iím doing something wrong. Can someone help please? Is there a setting problem?

thanks
mrdinh is offline   Reply With Quote
Sponsored Links
Old Oct 2, 2002, 10:34 AM   #2
Senior Member
 
Join Date: Aug 2002
Posts: 610
Default

Did you set your flash on the TTL mode? the recyle time is vary everytime base on the lighting condition of the subject (if the flash and camera's setting are on TTL or automatic mode). If the flash was set at the manual mode, it will fire with full power, there for it will take a longer time to recyle. The D1X has some custom functions that may prevent the flash to fire in some modes, you have to go through the set up procedures to set up the camera and flash for the D-TTL flash operation using the operational manual. After you do this, and you still have the same problem, then the flash may be defective, anh you may have to bring it to a local camera to test it out or for warranty services
tuanokc@hotmail.com is offline   Reply With Quote
Old Oct 2, 2002, 10:04 PM   #3
Senior Member
 
Join Date: Jun 2002
Posts: 194
Default

another thing is that i can't test flash using the test flash button no more...it used to do it fine...
mrdinh is offline   Reply With Quote
Old Oct 8, 2002, 9:23 AM   #4
Senior Member
 
Join Date: Jun 2002
Posts: 194
Default

we'll suddenly the prob went away...my speedlight seems normal again...

but weird thing is that if the flash doesn't fire right away...i increase the flash compensation....then it works fine...it seems like the flash needs to wake up...and this is how...
mrdinh is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:36 PM.