Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Fujifilm (https://forums.steves-digicams.com/fujifilm-22/)
-   -   A345 Problem Getting Power On (https://forums.steves-digicams.com/fujifilm-22/a345-problem-getting-power-84838/)

BrierS Mar 27, 2006 7:45 PM

My Mom has a FujiFilm A345 that has a terrible habit of not wanting to power up. I brought home and found certain fully charged batteries will work while other don't seem to. My initial thought is something is wrong with the battery compartment yet I am not certain. Has anyone had a similar problem? Possible solution? Thanks.
Steve

rinniethehun Mar 27, 2006 8:25 PM

Try cleaning the battery contacts. Sometimes they oxidize and restrict the flow of current.

the Hun


BrierS Mar 27, 2006 8:31 PM

Thanks again. You opined on my glass photography. Though not indicative one way or the other, the camera has acted like this since she got it. She said she just kept changing batteries. This evening I tried cleaning the battery contacts but still no improvement. I hate to send it in under warranty yet that may have to be the only way she won't get discouraged. Mom is just over 80 and has been learning to use digital and her computer at the same time. That leads to lots of extra for me . . .
Steve

rinniethehun Mar 27, 2006 9:31 PM

Is it possible that the batteries aren't being fully charged? Or perhaps one of the two batteries is defective? If some batteries are working, that leads me to believe that the others may be the problem. Any way you can test the battery output when fully charged?

Good for your mom...she has entered the technology era. Better get her camera working before she reverts back to film (LOL).

the Hun



All times are GMT -5. The time now is 5:58 PM.