Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Fujifilm (https://forums.steves-digicams.com/fujifilm-22/)
-   -   S9600 dusty display (https://forums.steves-digicams.com/fujifilm-22/s9600-dusty-display-137831/)

darkovsky Mar 5, 2008 11:11 AM

I bought my 2nd S9600 3 weeks ago, and already I have a little bit of dust inside the display. It doesn't affect pictures, but it's quite anoying. Does anyone else have/had this problem? I had one S9600 before this, 1 year old and the display wasn't dusty at all.
Thanks for Your answers!

darkovsky Mar 21, 2008 1:59 PM

So, no one with this problem? Till today, the display is even worse. Any recommendations?

rinniethehun Mar 21, 2008 7:38 PM

Sorry, but I don't have your particular camera model, nor have I heard of your particular problem. When you say dusty display, do you mean you see spots or something inside the EVF? Or you see something on the LCD? Since it doesn't affect the pics, it must not be on the sensor or the inside of the lens. You say it is getting worse...I don't think dust can multiply. Maybe you have mold growing inside the cam?

Sinice you've just bought the camera, you should be able to return it for exchange.

Good luck.

the Hun


darkovsky Mar 24, 2008 3:15 PM

Thanks for your answer. So, the dust is not in the sensor, nor in the EVF, it is inside the display. When I say it's gettin worse, I mean that more dust came in. I will try to take a picture of the display tomorrow


All times are GMT -5. The time now is 10:02 PM.