Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Fujifilm dSLR

Reply
 
Thread Tools Search this Thread
Old Sep 14, 2006, 6:57 PM   #1
Senior Member
 
D.Ann's Avatar
 
Join Date: Jun 2006
Posts: 2,932
Default

Well, the estimate came back on the S1 and the cost was over $700...guess I will be shopping again, but more carefully this time. Donna
D.Ann is offline   Reply With Quote
Sponsored Links
Old Oct 6, 2006, 9:12 AM   #2
Senior Member
 
wrams's Avatar
 
Join Date: Oct 2006
Posts: 490
Default

Perhaps you ought to complain to e-bay!!
wrams is offline   Reply With Quote
Old Oct 6, 2006, 9:39 AM   #3
Senior Member
 
D.Ann's Avatar
 
Join Date: Jun 2006
Posts: 2,932
Default

Well Icomplained to the guy who sold it to me...but to be honest he said he didn't know if it worked because he had no lens, (I found out he bought it at an auction, not always a good sign). The main circuit board was shorting out...I just sold it for parts on ebay. I was clear that it didn't work. Do you have fuji pro? I am still interested...I always loved the fuji colors. Donna
D.Ann is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:28 PM.