Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Fujifilm dSLR

Reply
 
Thread Tools Search this Thread
Old Feb 28, 2013, 10:46 PM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 3
Default Fuji HS25EXR and Yongnuo RS-603 triggers

Hi All,

I just recently purchased the RS603 triggers for use with my HS25EXR. I have followed all setups but cannot get these triggers to fire either of my flashes.

Has anyone had any experience with these triggers on the HS cameras? Any help would be greatly appreciated.

CJ
CJO_25EXR is offline   Reply With Quote
Sponsored Links
Old Mar 1, 2013, 3:14 PM   #2
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day CJ

I use the Y-301 triggers with my Y-460 flashguns on my X-s1 camera

In the camera shooting-menu, screen #4 is an option for External Flash on/off - with 'off' as the preset. You will need to swap this over ... For me in order to not upset any of my P-A-S-M settings, I go to "C1" custom, and set external flash to 'on' and leave it that way.

Hope this helps a bit
Regards, Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Mar 2, 2013, 12:01 AM   #3
Junior Member
 
Join Date: Feb 2013
Posts: 3
Default

Thanks Phil!

I did try turning on the external flash and the custom set but still cannot get the triggers to communicate. I'm testing these with an old Sunpak 1600A on manual and also a Vivitar SF-4000.

I'm begining to think the triggers are just not compatible with the HS25's hot shoe. Or there some other setting I'm missing. The triggers are both set to frequency 12.
CJO_25EXR is offline   Reply With Quote
Old Mar 2, 2013, 3:34 PM   #4
Senior Member
 
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,907
Default

G'day CJ

A lot of this is "I dunno - .... "

I can't find the 603 triggers on the Yongnuo shop site - plenty of 602's tho

My 301's have a single hot-shoe terminal + 2 flick switches each with 2 positions, so it's easy for me to flick 'em to & fro to either join 'em all or separate some

A few years back I had 2x Vivitar 4000's and they gave me problem after problem - so I dumped them for the Y-460's

I now have 4x 460's used for classroom /workshop studio work and they all work like a charm

Dunno whether this helps at all
Regards, Phil
__________________
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Mar 6, 2013, 5:46 AM   #5
Junior Member
 
Join Date: Feb 2013
Posts: 3
Default

Thanks again!

I have since returned the 603's for incompatibility and ordered a set of 301's. I may need to also get another flash.

I'll let you know how the 301's work out. Thanks again for all the help.

CJ
CJO_25EXR is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:36 PM.