Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Oct 31, 2006, 5:21 AM   #1
Junior Member
 
Lankan Photographer's Avatar
 
Join Date: Oct 2006
Posts: 3
Default

Dear Friend,

Very recently I bought a Fuji Finepix S9500. I am still in the process of learning about the camara. If anybody in this forum owns a FUJI S9500, please help me by giving me some tips for using the camara & Some photographic methods that you use.

Thanks,

Arantha.
Lankan Photographer is offline   Reply With Quote
Sponsored Links
Old Oct 31, 2006, 10:54 AM   #2
Senior Member
 
Join Date: May 2005
Posts: 1,063
Default

Your question is a difficult one to answer. It is about like asking someone how do you drive a car or how do you fly an airplane. The 9500 is a versatile camera. I live in the U.S., so I have the 9000 which is the same camera. The first thing I would say is, if you don't like your initial results, don't blame the camera. This model really does take some getting used to. I would set the ISO to 100 or 200, never on auto. I would not use Auto exposure. I would either use aperture preferred or programmed auto. For outside daytime photography I would suggest using a -1/3 to -2/3 EV compensation. For flash pictures, I would start out using the Auto mode or the programmed Auto mode. For best results with landscapes, try to avoid shooting between 10 AM and 2 PM.

The best thing I think you can do is just take a lot of pictures. Try different settings and different ideas. See which ones work and try to evaluate why some of them fail. Then, go take a bunch more pictures and repeat the process again and again and again. The camera will produce remarkable results for you. Just don't expect every picture to be perfect to begin with, do a lot of experimenting. You would be well advised to expect to do some postprocessing. You might want to consider purchasing an image editing program. They can really help you enhance some of your photos.

Good luck with the new camera. Welcome to the forum. We will look forward to hearing more from you.
jphess is offline   Reply With Quote
Old Oct 31, 2006, 11:12 PM   #3
Junior Member
 
Lankan Photographer's Avatar
 
Join Date: Oct 2006
Posts: 3
Default

Thanks alot for your valuable information on how to use a S9000. I am still a beginner to this Camara & to Photography. But I really love experimenting with my S9500. Please Update me in the latest findings you do on your S9000.

Thanks again,

Arantha
Lankan Photographer is offline   Reply With Quote
Old Nov 6, 2006, 2:59 PM   #4
Junior Member
 
Aero's Avatar
 
Join Date: Mar 2006
Posts: 22
Default

[align=left]Hi!
I allways carry tripod with me (day -times too). I use almoust allways manual settings and take several shots with different adjustements... so there is some good ones with them (one at east usually).
I have 2 extra flashes witch can be used at the same time (Other with caple).
I should buy monopod also...

Then I use one teleconverter made by Sony, when needed, (58mm)x1,7 and the quality of that is very good!

So... just take thousands photos and learn from it... like other cameras.

It is good eguipment for it's price!!!

- Aero
[/align]
Aero is offline   Reply With Quote
Old Nov 7, 2006, 9:52 AM   #5
Junior Member
 
Join Date: Oct 2006
Posts: 2
Default

Dear Guys ,I also have a finepix 9500 .It's nearly a year I have this camera and it gives an focus error everytime I turn on the camera .When you turn it off and on again the message dissapears ,It also is a little slow on focusing then. The pictures I take (daytime ,outdoor) look like there's a lot of noise inthem (kind of foggy).

Is there someone facing the same problem ,or is there something wrong with the settings I use (iso 100, EV -1/3, S or M scene).

I also use an external flash (metz mecablitz 44 MZ-2)with the standard sca 301 adapter .So I have to adjust manually everytime .Is there a another sca adapter I can use or is there an average setting for the flash if using the 301 sca adapter

Please let me know ....

Rewish

Paramaribo , Suriname
djonkoboy is offline   Reply With Quote
Old Nov 11, 2006, 7:15 PM   #6
Junior Member
 
Aero's Avatar
 
Join Date: Mar 2006
Posts: 22
Default


Hey!

Now it is happened to me also: Command Dial don't work!
Yesterday it was allright, but when I trying to do some shots with manual it just don't do nothing!
I'am BLOODY disappointed!!!
After about 4000 pictures and this is result of this journey with Fuji S9500!!!

Otherwise it was quite allright.

:[
Aero is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:48 PM.