Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jan 16, 2007, 5:18 PM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 2
Default

I have a FujuFilm FinePix S5000 and I love it, however a couple of weeks ago it wouldn't power on. I've taken good care of it and it hasn't been dropped or anything. Strangely enough if will come on if I hook it up to AC. I have tried replacing the batteries with brand new ones and still no luck.

Are there any suggestions outside of sending it to be repaired and spending a fortune?

- Jacob
jacobj86 is offline   Reply With Quote
Sponsored Links
Old Jan 17, 2007, 5:14 AM   #2
Member
 
Join Date: Jun 2002
Posts: 88
Default

jacobj86 wrote:
Quote:
Strangely enough if will come on if I hook it up to AC
Very common fault and 99% of the time it's one of two faults.

- A piece of the AC Tip breaks off and jams the Battery change/over tab (oFF). Check inside the plug to see if the tab is jammed OUT.
- Leakage / residue / oxidation from batteries etc insulates the Battery terminals. Use a QTip in alcohol and wipe all Terminals. If you see signs of oxidation, then you'll need a more abrasive chemical first ie Brasso.
Try that
JKirk

jkirk@oz is offline   Reply With Quote
Old Jan 17, 2007, 11:06 AM   #3
Junior Member
 
Join Date: Jan 2007
Posts: 2
Default

[email protected] wrote:
Quote:
jacobj86 wrote:
Quote:
Strangely enough if will come on if I hook it up to AC
Quote:
Very common fault and 99% of the time it's one of two faults.

- A piece of the AC Tip breaks off and jams the Battery change/over tab (oFF). Check inside the plug to see if the tab is jammed OUT.
- Leakage / residue / oxidation from batteries etc insulates the Battery terminals. Use a QTip in alcohol and wipe all Terminals. If you see signs of oxidation, then you'll need a more abrasive chemical first ie Brasso.
Try that
JKirk
Quote:
I cleaned the battery terminals with no luck. But in reference to the AC tip breaking off, what exactly would I be looking for? Do I need to look in the hole where the adapter goes in?
jacobj86 is offline   Reply With Quote
Old Jan 17, 2007, 4:45 PM   #4
Member
 
Join Date: Jun 2002
Posts: 88
Default

"I cleaned the battery terminals with no luck. But in reference to the AC tip breaking off, what exactly would I be looking for? Do I need to look in the hole where the adapter goes in?"

YES. There is a spring tab along the outer edge of the inside of the socket. It is pushed out when the plug is inserted, breaking the Battery contact inside. OFTEN, it gets jammed, either by a bit of plastic from a broken tip, or even permanently bent out by a bad plug. Remove the batteries and use, say a paper clip, to see if it still has any spring in.
JKirk

jkirk@oz is offline   Reply With Quote
Old Jan 31, 2007, 2:34 PM   #5
Junior Member
 
Join Date: Sep 2003
Posts: 4
Default

My S-5000 loses it's settings (clock etc.) when I change batteries, and the beep sound works sometimes ok and sometimes it's silent. Is this a common problem too? I wonder if there is a simple backup battery hidden inside somewhere...
melarry is offline   Reply With Quote
Old Feb 15, 2007, 7:55 AM   #6
Senior Member
 
Join Date: Jan 2006
Posts: 146
Default

I undestood there is a 3 V battery inside the camera (CR serie) wich keeps the settings - date, ISO, etc. I didn't have the nerve to try to change the one in my camera - yet!
vidiac is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:18 AM.