Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Jul 14, 2003, 2:43 AM   #1
Member
 
Join Date: Nov 2002
Posts: 52
Default lens and flash out of sync on 2650... need help

Greetings all,

Greetings all,

I have the Fuji Finepix 2650 and the flash and lens are out of sync making any pic taken in low light comes ouut almost black. My local camera store confirmed this and wants to charge me $110.00 to fix it. I paid $200.00 for the camera and I'm thinking of just junking it and getting the Olympus C-5050 which I've had my eye on since January.

I'm not really interested in spending half of what I paid for my camera just to fix it when I can get a nice 5 MP camera for under $500.00.

What should I do?

FRom,
Joe
JoeBoeing is offline   Reply With Quote
Sponsored Links
Old Jul 14, 2003, 6:24 AM   #2
Senior Member
 
Join Date: Aug 2002
Posts: 2,162
Default

Have you tried all the flash option settings in case it still works on say red eye or forced mode?
voxmagna is offline   Reply With Quote
Old Jul 14, 2003, 9:41 AM   #3
Member
 
Join Date: Nov 2002
Posts: 52
Default

Greetings again,

Yeas, I have... the pictures that did come out were of horrid quality. Extreemly grainy.

Well, my parents said that they would pay $150.00 - $200.00 if I were to get the C-5050. I may just go that route.

From,
Joe
JoeBoeing is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:15 AM.