Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Reply
 
Thread Tools Search this Thread
Old Mar 17, 2008, 8:14 PM   #31
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Barry-

Good Luck to you especially on this St. Patrick's Day! Vivitar lenses come from a wide variety of suppliers. I hope that you got one of the good ones, my friend.

Sarah Joyce


mtclimber is offline   Reply With Quote
Old Mar 23, 2008, 5:36 PM   #32
Junior Member
 
Join Date: Feb 2008
Posts: 1
Default

I wonder if anyone can tell me what I now own?

I have a Fujifilm S-800 camera (at least that is what is says on the box) and for some reason when I send a picture via Email most of the time it does not arrive with the Email.

Is is my camera or my Email setup?

Also, why can I never find any reference to the S-800 model on any website? I have gone to the Fujifilm website and found nothing.

Dan Keefe

Vista, CA


Dan Keefe is offline   Reply With Quote
Old Mar 23, 2008, 5:43 PM   #33
Member
 
Barry in Dallas's Avatar
 
Join Date: Oct 2007
Posts: 77
Default

Maybe it's because it's basically an s700 with one extra megapixel and not worth re-reviewing it. nothing else is different about it. the s700 also retains it's value, I sold mine two weeks ago for almost as much as I paid for it last August

Barry
Barry in Dallas is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:13 AM.